Jump to content
Sign in to follow this  
Followers 1
Alboy

Cannot connect GPS 60 to PC

Recommended Posts

Hi all

 

I have been lent a GPS60 to have a play with in advance of taking it out on a walk with me. I've plotted the walk on Memory Map and now need to get the 60 or so waypoints onto the GPS.

 

I loaded the software that came with the GPS and followed the instructions carefully but when I plug the GPS into the PC it does not recognise the USB Device. I get the little trident USB icon in the bottom right of the start bar. When I double click it just says Unknown Device and says the device has malfunctioned. When I look at properties and try and force an association via Control Panel - System - Devices etc with the driver on my PC that fails too.

 

I've gone online, downloaded the latest drivers, the latest waypoint management software etc, but the PC just will not recognise the GPS there.

 

I've checked everything - the cable works with other kit, I've tried other cables. I've even tried it all on my work PC as well but no joy. The same thing. The PC does not recognise the GPSr.

 

The GPS seems to work OK aside from this issue.

 

Has anyone else had this problem, or does anyone have any ideas as to other things I can try?

 

Many thanks

Edited by Alboy

Share this post


Link to post

I think you're probably on the right track as far as the driver goes.

 

My approach would be to try to get everything back to 'initial conditions'.

 

With the device connected, remove the device from the device manager.

 

Uninstall the USB drivers.

 

Check on the GPS, and see what the communication mode is set to (should be Garmin).

 

Redownload, and reinstall the latest USB drivers.

 

plug the gps in to a different port.

Share this post


Link to post

Just a stupid question... (Don't feel offended, I ask stupid questions all the time! LOL)

 

Have you tried using GSAK (or another program) to send waypoints to the 60? Even though you've got that error message?

 

I only ask this because when my 60CSX is connected, I cannot access it through "My Computer". BUT, everything loads on it just fine.

 

It does not show up in the list of USB devices connected.

 

I attach my 60CSX to my computer, then turn it on. I hear the bong that Windows makes when you connect a USB device.

 

I send my waypoints over using GSAK, I check to make sure they are on the unit, and then power off the receiver.

 

I hear the bong (Windows telling me a USB device has been disconnected) and all is well.

 

When you plug in your GPSr, do you see a little plug in the upper left hand corner of the GPSr? (Meaning it's plugged in.)

Share this post


Link to post

Thanks for the reply. I havent actually tried sending anything to the GPSr and will, but I hav looked on the Interface Setting and it says that it is not connected, so it seems the GPS does not think it is accepted.

 

If it works though I'll be sure to let you know!

 

thanks again

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 1

×
×
  • Create New...