Jump to content

reproducable map error


Juicepig
Followers 1

Recommended Posts

If you scroll to the area North of scarborough, Ontario, Canada - there seems to be a cache that has a funky character (or something) that is messing up the map program (IE7 only tested)

 

The error is this: 5c0b7b18-5acf-4a25-b1de-0d815fff895a.jpg

 

It pops up if this cache is in the screen... although I cannot determine for sure which cache it is... but i have a suspect! http://www.geocaching.com/seek/cache_detai...9e-453eb6c6dd24

 

Try clicking here:

http://www.geocaching.com/seek/gmnearest.a...mp;lng=-79.0805

Edited by Juicepig
Link to comment

I ran into this problem when programming the waymarks back into the map (Greasemonkey). The problem I ran into was with double quotes. You can add that to your list of unsafe characters.

 

The problem is these literals do not work with JSON deserialization. For the double quotes, I replaced them with two single quotes--pretty much indistinguishable with the font used on the page. To fix the problem from this reported defect, I replaced the backslashes with forward slashes. Unfortunately for Groundspeak, you all have to find a way to display the literals and not a way around it.

 

I do have an efficient JavaScript function that will fix everything you need, along those terms, to display the names correctly for JSON deserialization for waymarks and geocaches. Hmm... If it'll take Groundspeak a few weeks to fix, should I put out a Greasemonkey patch? Just as long as the csae(c,o,e) function is overridden correctly, that is.

Link to comment
Guest
This topic is now closed to further replies.
Followers 1
×
×
  • Create New...