Jump to content

Garmin ETrex Legend...blue line of death?

Followers 1

Recommended Posts

Hi, I am wondering if anyone else who had a Garmin eTrex Legend has ever been out geocaching, only to look down and see that the entire screen has disappeared, and in it's place there is only a thin blue line running down the left hand side of the unit's screen. This has happened to me twice recently. Once while in the car heading towards a cache, and another time while we were out searching for a cache. Please don't tell me my unit is dying <_<:mad:

Link to comment

I ran into this problem with mine before going out caching one day. I turned it on & tossed it up on the dashboard to get a signal,. when I picked it up... blue line. So I took the batteries out of my flashlight & put them in, same thing. Last time I turned it off & back on (might have had to pull the batts, not sure) I just held it in my hand & out of the jeep window until it picked up & it never blue lined again. I have no idea what caused it, if it was somethign the dashboard was spitting out, or just bad batteries.

Link to comment

Just smack the left side of the GPS gently but firmly against your left palm. Works with my last 4 Garmin Legends. All had the same exact issue. It's a factory defect of a loose connection they never seem to get fixed. I just upgraded to the Oregon 550T.

Link to comment

Garmin has a fix (update) for this problem if you have the proper interface cable. If not, simply disable WAAS in setup. THIS WORKS!

I have seen this behavior in two units (GPSmap 76 and GPSmap 76S). BUT, that was back when the second WAAS satellite had been put into orbit. Disabling WAAS was a workaround. Upgrading the software was the fix. So, if your unit has been functioning OK till very recently, this is not the problem. Now, pull an older Garmin unit (without the latest update) out of your sock drawer after a long period of storage, and you might have the WAAS problem.

Link to comment

I have the problem with mine, but ONLY when I use rechargable batteries with my old cheap charger (which I think overcharges). The problem supposedly is worse with lithium batteries too (which I never used).


I found as some have suggested that whacking the unit seems to help, but what helps even more was to pull the batteries and put them in a flash light or something for several minutes. Worked every time.


Once I went to a new charger, I never saw this problem again, unless I got behind on battery charging and pulled the old charger back out.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 1
  • Create New...