Jump to content

E-mail Formatting Changed -- for the worse


RubberToes

Recommended Posts

Each time the software for the new maps gets turned on, all of the e-mail I receive from the site is formatted strangely.

 

All of the returns are missing and the text and links are all slammed together.

 

Also, I seem to get most everything twice.

 

The "This is an automated message from Geocaching

You are receiving this email because you have bookmarked this listing. Visit the web site to change your bookmark list settings" message arrives only once ...

 

However, the remainder, including the log entry and the links to the cache, bookmarks, and profiles all comes twice, and all in one paragraph.

 

Thank for looking into this.

Link to post

Can't say that I realized any link between this problem and beta testing of new maps. I am not getting everything twice. But I certainly do see periods of strangely formatted email with returns missing and text and links all slammed together.

Link to post

This is what the most recent message looked like: B)

 

This is an automated message from Geocaching

 

For GC16JWZ: Hallowed Ground - A Disused Graveyard (Traditional Cache) Location: California, United States 24.3mi W (39.1km W) Marko Ramius published Hallowed Ground - A Disused Graveyard (Traditional Cache) at 10/10/2007 Log Date: 10/10/2007 Published Visit this log entry at the below address: http://www.geocaching.com/seek/log.aspx?LU...fb-9963a0bd878c Visit Traditional Cache Hallowed Ground - A Disused Graveyard http://www.geocaching.com/seek/cache_detai...11-790e325d0926 Profile for Marko Ramius: http://www.geocaching.com/profile/?guid=ba...c9-7b03b070dca5 Notification: New Traditional Caches http://www.geocaching.com/notify/edit.aspx?NID=11688

Normally there are actual paragraphs between the information and the links.

Link to post

The emails are still coming in all crowded together this morning . . .

 

Here is what one looked like:

This is an automated message from Geocaching

 

For GCH1M1: Fishing Buddies (Archived) (Traditional Cache) Location: California, United States 21mi NE (33.8km NE) "Flintstones" archived Fishing Buddies (Archived) (Traditional Cache) at 10/10/2007 Log Date: 10/10/2007 This cache has finaly gone MIA. Please archive. Visit this log entry at the below address: http://www.geocaching.com/seek/log.aspx?LU...48-9a31f2ea689c Visit Traditional Cache Fishing Buddies http://www.geocaching.com/seek/cache_detai...8f-105ccb780163 Profile for "Flintstones": http://www.geocaching.com/profile/?guid=3b...51-273188503c60 Notification: Archived http://www.geocaching.com/notify/edit.aspx?NID=63662

Link to post

Same problem here for several days now:

You are receiving this email because this listing is on your watch list. Visit the web site to change your watchlist settings. Location: Washington, United States W42.COM found Depot Drop (Traditional Cache) at 10/4/2007 Log Date: 10/4/2007 Quick find on suprise visit. Log a little bit wet needs new bag. Thanks Visit this log entry at the below address: http://www.geocaching.com/seek/log.aspx?LU...6a-22e725c689d1 Visit Traditional Cache Depot Drop http://www.geocaching.com/seek/cache_detai...fa-b01d9678998a Profile for W42.COM: http://www.geocaching.com/profile/?guid=2b...fb-3af46d69039f Remove from watchlist: http://www.geocaching.com/my/watchlist.asp...&ACTION=REM

 

Is the problem being addressed?

Link to post

This morning, the emails are looking a bit better, but they still aren't back to normal. The links used to be separated on their own lines.

You are receiving this email because you are the owner of this listing. Location: California, United States habu! found Tippecanoe and Tyler Too (Traditional Cache) at 10/11/2007 Log Date: 10/11/2007 I came down to visit with SKILLET but I keep stoping to grab another smiley. The way I look at it;

 

 

A cache a day keeps LLOT and Jack at bay [
:D
)][
:anitongue:
)][
:laughing:
)] Visit this log entry at the below address:
Visit Tippecanoe and Tyler Too
Profile for habu!:

Link to post

Something about this problem affects other emails from geocaching.com. If I reply to an email from a geocacher, his original message loses all line feeds. I mean, his original message seems fine in my email client but looks are deceiving since the carriage returns/line feeds are not actually there as is plainly evident when replying or forwarding the original message.

Sounds like an incompatability between UNIX and Microsoft but I know that's not it.

Link to post

I had someone DNF my newest cache hide and I did not receive the email. Fortunatly the next person to DNF it sent me a private email. Does a responsible cache owner now have to regularly check all their cache pages? Forget adding a whole lot of new features if it means breaking the most important old ones.

Link to post

If a cache owner HAS to check his caches regularly then it would be nice for Geocaches (Mine) to show not just the Date of the last Found Log, but the last Log (Of Any Kind).

 

More useful for people with hundreds of caches planted, but nice for all others also so one does not have to click on each of ones caches and page down to the most recent log...

 

Oh, and it's a good thing for a cache owner to keep his [Log] emails, if he gets them, since if a finder deletes his log you can still link to it. Otherwise it's lost in limbo unless you remember the 50 digit long GUID code URL.

 

P.S. You will not get an email stating that a cache finder deleted his log. I wonder why.

But you will get an email if a cache placer deletes one of your logs.

Link to post

If a cache owner HAS to check his caches regularly then it would be nice for Geocaches (Mine) to show not just the Date of the last Found Log, but the last Log (Of Any Kind).

That would work for me! And now that I've been burned once that link would go to the top of my Favorites list.

 

P.S. You will not get an email stating that a cache finder deleted his log. I wonder why.

But you will get an email if a cache placer deletes one of your logs.

The first instance does not affect YOUR find count, and it's not your log (you didn't write it).

The second instance does affect your count, and it is your log because you wrote it.

Best reasons I can think of.

Link to post

The first instance does not affect YOUR find count, and it's not your log (you didn't write it).

The second instance does affect your count, and it is your log because you wrote it.

Best reasons I can think of.

 

Sure the first count does not effect my stats. But it effects the Logged visits and cache stats, those little numbers next to those cute little icons. These should never decrease without notification.

 

I only know of a log someone posted on one of my caches and a month later he deleted it since I talked with the person in question. Long ago I had deleted the original posting emails, my goof, but no more.

Link to post

FYI

 

I mailed GC about this, october 15th I got a ticket (already closed) and this answer:

 

Hello,

 

Thank you for writing us. At this time, this feature does have some bugs and we are aware of them. Our development team is looking into it. In the meantime, you may wish to consult our forums.

 

http://forums.Groundspeak.com/GC/index.php?showforum=8

 

Eric

Groundspeak, Inc.

 

I sincerely hope they are looking into this flaw, my watchlist logfiles are nearly unreadable.

 

Barjon.

Link to post

I just got another Bookmark notification this morning and the bad formatting is still present: :ph34r:

This is an automated message from Geocaching

 

 

You are receiving this email because you have bookmarked this listing. Visit the web site to change your bookmark list settings. Location: California, United States asaxist found Tufa Towers (Earthcache) at 10/18/2007 Log Date: 10/18/2007 Found again after being here some 30 yrs ago. This place is really incredible, is'nt it? Thanks for bringing me back, it 's worth the $3 and the long drive. Visit this log entry at the below address:
Visit Earthcache Tufa Towers
Profile for asaxist:
Bookmark List "Memorable Caches":

I guess what I don't understand is why there is a space -- a big space -- between

This is an automated message from Geocaching

and the rest of the message, but no spaces between the other lines where there were spaces before . . . :surprise:

 

It must be very complicated since it is taking this long to fix . . . :)

 

However, I am thankful to be receiving all the notifications, even if they are difficult to comprehend . . . ;)

Link to post

I have not seen the formatting issue but have noticed with some consistently that when I try the link that should take me directly to the cache page in a Watchlist or Bookmark email link, I get the Server busy error that is similar to the one I get when the site is busy.

 

I would chalk it up to the site being busy except that I can click on any other link in the email and it takes me to the site fine.

Link to post

Email formatting is a puzzlement for sure.

 

I just checked my profile. I still have the box checked that says to send emails in html format. Does this mean the emails that I send to other cachers through gc.com or emails that gc.com sends to me?

 

I use Entourage for receiving most of my email on my mac. Until this recent round of updates by gc.com, all worked fine. Now, I receive a message that seems devoid of line breaks. The message appears in a very small, generic font. I have difficulty determining which link is for the log, the cache and the profile of the gc.com person who sent the cache announcement to me. When I do click, since everything is so small and close together, I often get the wrong link anyway. I will soon have the reviewer's profile memorized.

 

However, if I use Horde as my email client, or check my mail with my gmail account, the message has line breaks, the font is larger and more legible, and I have no difficulty with the email at all.

 

The problem must be in some command or special character that was in the header of the sent email prior to the updates that is no longer there.

 

I hope this gets repaired. As of today, it is still broken for Entourage on my mac. I am running OS 10.4 on an Intel based MacBook Pro. My Entourage is version 10.0

Link to post

The email malformatting continues to be a major annoyance for me. At least in my case, it's also causing extra load on the gc.com servers. The reason is that I often don't even try to read the email notifications, just locate the cache page link and click it.

 

Edward

Link to post

I'm sorry everyone, this bug was closed without my knowledge (reason: not reproducable). Apparently the email formatting was checked and found to not have any issues. They are HTML emails so for those of you with "test format" checked in your profile you should switch to "HTML format".

 

If that still doesn't work I'll need for you to post which email program you're using so I can investigate further. Thanks.

Link to post

I'm sorry everyone, this bug was closed without my knowledge (reason: not reproducable). Apparently the email formatting was checked and found to not have any issues. They are HTML emails so for those of you with "test format" checked in your profile you should switch to "HTML format".

 

If that still doesn't work I'll need for you to post which email program you're using so I can investigate further. Thanks.

 

Maybe the list of all bugs that are closed out should be checked to see that they didn't mysteriously/accidently get closed out without actually getting fixed.

Link to post

I'm sorry everyone, this bug was closed without my knowledge (reason: not reproducable). Apparently the email formatting was checked and found to not have any issues. They are HTML emails so for those of you with "test text format" checked in your profile you should switch to "HTML format".

 

If that still doesn't work I'll need for you to post which email program you're using so I can investigate further. Thanks.

Fixed for you..... :unsure:

 

(small format issue)

Link to post

I'm sorry everyone, this bug was closed without my knowledge (reason: not reproducable). Apparently the email formatting was checked and found to not have any issues. They are HTML emails so for those of you with "test text format" checked in your profile you should switch to "HTML format".

 

If that still doesn't work I'll need for you to post which email program you're using so I can investigate further. Thanks.

Fixed for you..... :unsure:

 

(small format issue)

 

Ah yes, thanks for that. :unsure:

Link to post

I have it set for html. It comes through gmail working perfectly. When it gets to Eudora, it stops having line breaks.

 

I do software support for several programs and have pretty much always found that if it works in one program but not in another then you need to be figuring out what is different in the program that isn't working. I receive my geocaching email at work in Outlook and they are forwarded from my account with my ISP. I see the line breaks in both account with no problems.

 

If Gmail works and Eudora doesn't it sure seems like the problem is with Eudora. The sender of an email can't control the settings for every email package people are using. I would be looking at the settings at the receiving end to figure out the problem.

 

Flame retardent suit is now on. :unsure:

Link to post

The emails used to be formatted correctly in Eudora. Then they started being all crowded together. I have Eudora set for HTML and get other HTML mail just fine, including images.

 

Something changed with the GC.com mail back in October when the site went through the big changes. It is true the messages are formatted correctly in gmail . . . so it is weird that they are not formatted correctly in Eudora . . . as they used to be . . . :unsure:

Link to post

The emails used to be formatted correctly in Eudora. Then they started being all crowded together. I have Eudora set for HTML and get other HTML mail just fine, including images.

 

Something changed with the GC.com mail back in October when the site went through the big changes. It is true the messages are formatted correctly in gmail . . . so it is weird that they are not formatted correctly in Eudora . . . as they used to be . . . :unsure:

 

As Miragee states, same for me.

Link to post

Here is what a message looks like in Eudora:

This is an automated message from Geocaching

 

You are receiving this email because you have bookmarked this listing. Visit the web site to change your bookmark list settings. Location: Arizona, United States Exstreme_Rat_Psychosis found Cache Across America - Arizona (Traditional Cache) at 12/10/2007 Log Date: 12/10/2007 Found this one with Princess Lisa. Was a bit confusing figuring out the correct way to go with all the barbed wire around. Visit this log entry at the below address: http://www.geocaching.com/seek/log.aspx?LU...7d-72e04dc867b4 Visit Traditional Cache Cache Across America - Arizona http://www.geocaching.com/seek/cache_detai...6a-5d889e9e0311 Profile for Exstreme_Rat_Psychosis: http://www.geocaching.com/profile/?guid=c2...6c-af1df0e88116 Bookmark List "New Mexico Challenge - What's left for me?": http://www.geocaching.com/bookmarks/view.a...e0-01b955bb2987 Location: Arizona, United States Exstreme_Rat_Psychosis found Cache Across America - Arizona (Traditional Cache) at 12/10/2007 Log Date: 12/10/2007 Found this one with Princess Lisa. Was a bit confusing figuring out the correct way to go with all the barbed wire around. Visit this log entry at the below address: http://www.geocaching.com/seek/log.aspx?LU...7d-72e04dc867b4 Visit Traditional Cache Cache Across America - Arizona http://www.geocaching.com/seek/cache_detai...6a-5d889e9e0311 Profile for Exstreme_Rat_Psychosis: http://www.geocaching.com/profile/?guid=c2...6c-af1df0e88116

 

Here is the same message in gmail:

This is an automated message from Geocaching

 

You are receiving this email because you have bookmarked this listing. Visit the web site to change your bookmark list settings.

 

Location: Arizona, United States

Exstreme_Rat_Psychosis found Cache Across America - Arizona (Traditional Cache) at 12/10/2007

 

Log Date: 12/10/2007

Found this one with Princess Lisa. Was a bit confusing figuring out the correct way to go with all the barbed wire around.

 

Visit this log entry at the below address:

http://www.geocaching.com/seek/log.aspx?LU...7d-72e04dc867b4

 

Visit Traditional Cache

Cache Across America - Arizona

http://www.geocaching.com/seek/cache_detai...6a-5d889e9e0311

 

Profile for Exstreme_Rat_Psychosis:

http://www.geocaching.com/profile/?guid=c2...6c-af1df0e88116

I don't know why there is a difference, but prior to October, there wasn't a difference, except for one brief period earlier in the summer . . . That previous glitch was remedied, at least until October . . .

Link to post

Put me down as another Gmail / Eudora user that's still appears to be having issues. Honestly, I have pretty much stopped using Eudora now in lieu of Gmail's web client. The format still looks fine in Gmail.

 

If I get a wild hair up my butt, maybe I'll change the email address to something other than Gmail to see if it makes a difference. I wouldn't think so.

 

EDIT: So I switched the email to my Verizon account and got the same result. It's what I expected actually. Web mail for Verizon, which happens to be supported by Yahoo, seems to look fine. Is anyone having an issue with another mail client aside from Eudora?

Edited by Crew of Misfits
Link to post
If Gmail works and Eudora doesn't it sure seems like the problem is with Eudora. The sender of an email can't control the settings for every email package people are using. I would be looking at the settings at the receiving end to figure out the problem.

 

Flame retardent suit is now on. :D

Not so helpful since if we all knew what to turn on, we would. Plus as you can see from the other posts, it is not a matter of one person making a change that messed it up for them but of GS changing something that Eudora can't read/isn't reading right/etc.

 

To be helpful I'll try this...

 

What kind of line break was used in the old e-mails vs the new ones? Maybe the new line break is something not understood by eudora which is why we're seeing a difference.

Link to post

So Eudora is the culprit. Well this is not something that is likely to be fixed prior to Version 2 being released so if it isn't too much trouble I would suggest switching to gmail or some other freebie. Hate to make you guys switch, but with a bug this isolated it's difficult to devote scant resources to fixing it. Sorry to those of you using Eudora, I know you can get attached to your email.

Link to post

So Eudora is the culprit. Well this is not something that is likely to be fixed prior to Version 2 being released so if it isn't too much trouble I would suggest switching to gmail or some other freebie. Hate to make you guys switch, but with a bug this isolated it's difficult to devote scant resources to fixing it. Sorry to those of you using Eudora, I know you can get attached to your email.

The thing is . . . something on Groundspeak's side changed because I did not change versions of Eudora, an email client I have used for 12 years. Because I have such a slow dialup connection, I prefer getting my email into Eudora so I can read it even if I am not logged on . . . like if I am waiting for a phone call. :D

 

I'll live with it . . . but it sure would be interesting to know what happen on your end. This little glitch occurred briefly during the summer, then it got fixed.

 

It started in October when all the changes to the site were implemented. Seems like it wouldn't be too difficult to figure out what sort of code was used for the line breaks prior to the site changes vs. those used after all those changes . . . ;)

Link to post

It's not just Eudora as I also get compressed emails on my iPaq 2210 PDA.

 

I've looked back at some old watchlist emails and the problems started when the emails were sent using just a single LF character to terminate a line. Prior to that CR LF was used.

 

I downloaded the Windows version of Eudora 7.1.0.9 to try it out and also found that the emails were compressed. However if you install this plugin from here any new watchlists you receive will be nicely formatted ;) .

 

Gary

Edited by Gary & Jane
Link to post

. . . However if you install this plugin from here any new watchlists you receive will be nicely formatted :D .

 

Gary

Cool beans . . . ;) That works perfectly. I did the install, restarted Eudora and a Bookmark email came in immediately, perfectly formatted. Thanks, Gary! :D

 

- - - - - - - - - - - - - - - - - - - - - -

 

On Edit: Uh Oh . . . the link to the cache is all goofy. The email is formatted with the line breaks, but this is what the links look like now:

Caffine fixxed Commuter \ #5 Public Transit series

http://www.geocaching.com/seek/cache_detai...spxÝZYMÎLÍÙLÎ

ËLYŒŒKMÙ ËNM˜˜KML L YMØXÀa5

 

The link to the Reviewer's log is correct and I can click on it, but the link to the cache is all mixed up like that. A second one that came in tonight had the same problem. :D

Now, why would that be ?????? :D

Edited by Miragee
Link to post

On Edit: Uh Oh . . . the link to the cache is all goofy.

Sorry the plugin didn't help you out :unsure: . The odd thing is that it works fine for me! I had been playing around with the plugin settings and currently have them all switched off which might explain the difference. You could also try this and see if helps.

 

Gary

Edited by Gary & Jane
Link to post
On Edit: Uh Oh . . . the link to the cache is all goofy. The email is formatted with the line breaks, but this is what the links look like now:
Caffine fixxed Commuter \ #5 Public Transit series

http://www.geocaching.com/seek/cache_detai...spxÝZYMÎLÍÙLÎ

ËLYŒŒKMÙ ËNM˜˜KML L YMØXÀa5

 

Guess I spoke prematurely as well. The link is screwed up for me too. I didn't make any changes to the settings when I installed the plugin.

 

Bummer.

 

EDIT: Ok, so Gary is right. Go to Special | Message Plugin Settings. Select the UTF8 plugin and then click on settings. Make sure everything is unchecked. After I did that, it seemed to be fine. Don't forget to exit and reopen the application after making the change. Thanks again Gary.

Edited by Crew of Misfits
Link to post

Well, UTF8ISO doesn't do a darned thing for me. Not with any combination of options. (Win/Eudora 6.1.2. Never wanted to give Qualcomm any more money to support the brick wall that they called support.)

 

OpinioNate said I should change from text to HTML. Why the heck should I be forced to use HTML email for messages that are just text? In any case, I was using the HTML option -- I think I changed from text to HTML in the hope of getting better formatting, but it didn't help. I have just now changed back to text and will see what that does.

 

Look, people: if there's only an LF, not a CRLF, at the ends of lines, then it's broken. Period, end of topic. RFC2822 is abundantly clear on this point: lines end with CRLF. That's no matter what your platform of choice is. Most IMAP servers refuse to accept messages with "bare newlines" (that is, LF without CR). POP clients and SMTP software generally treat bare newlines as grandfathered to avoid isolating all the broken email software out there, but that doesn't make the offenders correct.

 

Not only that, but the headers are fouled up. Technically I think header names are not case sensitive. But what mailer creates headers named x-mailer, mime-version, date, subject, content-type (all with a lower case leading letter instead of the traditional upper case)? Even if technically correct, this shows a major lack of attention to detail.

 

Someone said that the HTML emails look OK in Outlook. I don't doubt it. When something that claims to be HTML displays as intended in Microsoft software and not somewhere else, I generally draw the conclusion that something is wrong with the HTML (like it isn't really HTML). Internet Exploder violates more of the HTML standards than all the other browsers put together.

 

Eudora certainly has its share of broken stuff, but in this case it appears to be gc.com that's broken.

 

Edward

Link to post

Well . . . before making changes to the Plug-In, some of the messages have come in with the links looking better. This is how one that came in this morning looked. Only the last link was screwed up. I could click the link to the new cache page.

Marko Ramius published Mi Chiquita (Traditional Cache) at 12/12/2007

 

Log Date: 12/12/2007

Published

 

Visit this log entry at the below address:

http://www.geocaching.com/seek/log.aspx?LU...89-1d80bca3e0d8

 

Visit Traditional Cache

Mi Chiquita

http://www.geocaching.com/seek/cache_detai...d2-b779c15779a0

 

Profile for Marko Ramius:

http://www.geocaching.com/profile/ÝZYX˜L

Ž ËXN

MKMÎ ËNMXÀ9-7b03b070dca5

:D
Link to post

OK, what I'm finding is that the plug-in does not work as advertised for previously received messages. However, it seems to be working for new messages, at least for plain text.

 

Caveats: for already-received messages, I mostly had HTML to try it on. I only had a couple of badly formatted plain text messages, and they were from mid-October, when the problem began. So for recent messages, the combinations I tried were:

 

HTML, already received: plug-in did not work.

 

Plain text, newly received with plug-in active: properly formatted.

 

I have NOT tried:

 

Newly received HTML with plug-in active.

 

Newly received plain text with plugin NOT active.

 

Plain text already received.

 

Others will have to do the remaining experiments if needed, since I'm now a happy camper. However, the fact remains that email with bare newlines is broken.

 

Edward

Link to post

I'm sorry everyone, this bug was closed without my knowledge (reason: not reproducable). Apparently the email formatting was checked and found to not have any issues. They are HTML emails so for those of you with "test format" checked in your profile you should switch to "HTML format".

 

If that still doesn't work I'll need for you to post which email program you're using so I can investigate further. Thanks.

OpinoNate,

 

When I go to my ISP's web mail server and open mail from Groundspeak.com it is formated correctly. But when I download the same mail to my email program (Eudora v7) and open them, the ones from Groundspeak.com lose all formatting as mentioned by others. Maybe that gives you some clue as to the problem.

Link to post
Guest
This topic is now closed to further replies.
×
×
  • Create New...