Jump to content
Sign in to follow this  
Followers 45
ibycus

Free Topo Maps for Garmin GPS

Recommended Posts

Looking for opinions...

Those of you who have downloaded the dataset may have noticed that in many cases, things like lakes, streams, rivers etc are nameless as an entity, but have an additional POI overlayed on top of them with what the lake/river/stream/etc is actually called.

 

For an example, have a look at N51 07.351 W114 24.069. You'll see Glenbow lake. If you hover over the actual lake though, its indicated as just being "Lake", with a point of interest object in the middle of it Called "Glenbow Lake". Or check out Pirmez Creek at N51 02.227 W114 26.108, notice how the label is horizontal, even though the river... isn't.

 

Is this something people care about?

 

Advantages I can see in doing it my way (which is also the most convenient way due to the data structure):

Searchability. If you look for "Glenbow Lake" in say Metroguide Canada 4, you won't find it (even though its in there, and named). If you look for it in my topo you will.

 

Disadvantage... I don't like the fact that the lake is there, but the lake itself isn't named I'd much rather mapsource controlled the labeling, then it could do things like adjust the angle, etc more appropriately. Also if you're looking at one little part of the feature, you may have to scroll around to find its name, rather than hover over top of it.

 

-----

Another option is for me to run some post processing on the data and try to associate these POI objects with a specific element on the map.

 

Advantages and disadvantages are basically reversed, no way to search for it, but its labeled by your GPS or by mapsource. One additional disadvantage, is the potential for me to make a mistake, and associate the wrong name to the wrong river/lake/stream. (I don't think this will be a problem, but the potential does exist)

-----

Final option... Do both. Leave the POIs in there, but attempt to properly associate a label with the right river/lake/stream etc.

 

Advantage: Searchable, also you can hover over any point in the associated object and get the name, mapsource will label it, and angle text appropriately etc.

 

Disadvantage: Double labeling. This might be mitigated somewhat by changing the zoom levels around a bit (so that you'll only see the POI label at high zoom), but in essence all the old labeling will stay there, you just now have more to contend with.

 

Thoughts?

Share this post


Link to post

Nice work.

 

I was going to let you know about some of the elevation errors in the 082 set, but I see you already have that covered!

 

082F04 has Red Mountain Resort on it, and the three ski lifts are labelled as powerlines... might be something you want to fix.

 

I also notice some of the sheets are missing, but I think you have that covered as well. I will be eagerly awaiting the updaed versions of this area.

 

Thanks a ton for this. I would have bought the Map Source package yesterday, but it wasn't in stock, you may have just saved me a bit of $$$.

 

I'd be happy to do some on the gruound fact checking for a few local sheets if that would help you get the POIs and stuff sorted out. Just let me know.

Share this post


Link to post

Nice work.

 

I was going to let you know about some of the elevation errors in the 082 set, but I see you already have that covered!

 

082F04 has Red Mountain Resort on it, and the three ski lifts are labelled as powerlines... might be something you want to fix.

 

Yep. All the cutlines (which I imagine is what is marked on the map, rather than the lift itself) are in as "powerlines" in not the coming up version, but the version after that, I intend to have this fixed (I've fixed the underlying problem, just have to wait until it filters through to the actual compiled versions).

 

I also notice some of the sheets are missing, but I think you have that covered as well. I will be eagerly awaiting the updaed versions of this area.

 

You can expect a new version shortly <_<. I'm in the process of compiling the installer which will cover 092, 082, 082, 084, 072, 052, 031, 021, 022 and 011. It will be about a 750MB download.

 

Thanks a ton for this. I would have bought the Map Source package yesterday, but it wasn't in stock, you may have just saved me a bit of $$$.

 

I'd be happy to do some on the gruound fact checking for a few local sheets if that would help you get the POIs and stuff sorted out. Just let me know.

 

To be honest, there isn't a whole lot I can do about bad data. What I'm really interested in comments about things like feature X is listed as Y and that just seems weird. Or "What the heck are all these points there for?", or things like that. (the reason I can't do a lot about bad data, is I'm constantly building and rebuilding these sets from source data, if I make a change, like add a road or something, it will disapear in the next revision.)

Share this post


Link to post

haha. "What the heck are all these points there for?"

there are soooo many POI's all labeled as 'Other'

it seems like everything shaded grey (green? treed areas) is indicated as Park when you hover over it, in much the same way you said the dark grey (blue? water areas) are indicated as Lakes.

But with the treed areas, there wouldn't be something proper to label it as, just strip it of its claim of being a park. (unless it happens to be a park I suppose)

 

I'm loving the detail and the accuracy. this is awesome. I have noticed one road problem, but that's to do with the data. It's a re-done hwy interchange that I always look at on a map to gauge how up-to-date it is. (just a little nerdy?)

Share this post


Link to post

haha. "What the heck are all these points there for?"

there are soooo many POI's all labeled as 'Other'

 

They actually have no label in my source file, but mapsource interprets that as Unknown/Other. I think I've fixed the underlying problem, and they should have labels next time I build the area. Believe it or not, I've already filtered the POIs layer back significantly (I think I may cut it back more, but I'll wait until I've released a version with all the labels on it, so people know what is what, and can tell me what they generally don't care about)

 

it seems like everything shaded grey (green? treed areas) is indicated as Park when you hover over it, in much the same way you said the dark grey (blue? water areas) are indicated as Lakes.

But with the treed areas, there wouldn't be something proper to label it as, just strip it of its claim of being a park. (unless it happens to be a park I suppose)

 

Hmmm, this is a similar problem to the above POI issue. Things with no label get a default label. in this case, its "State Park". I've changed it so that they'll come up as "Vegetation" the next time it gets compiled.

 

I'm loving the detail and the accuracy. this is awesome. I have noticed one road problem, but that's to do with the data. It's a re-done hwy interchange that I always look at on a map to gauge how up-to-date it is. (just a little nerdy?)

 

The BC data set should be accurate as of November 2006. You can check the validity date for the various areas on http://www.geobase.ca/geobase/en/data/nrn/status.html (although my Nova Scotia dataset is a little older than the one on the site...)

Share this post


Link to post

Seems to be taking much much much longer than I expected to create the MSI file (it ran overnight, and was still running this morning).

 

Does anyone know of any good (free) programs to create an MSI file?

Share this post


Link to post

Seems to be taking much much much longer than I expected to create the MSI file (it ran overnight, and was still running this morning).

 

Does anyone know of any good (free) programs to create an MSI file?

 

I'm using Inno setup. http://www.jrsoftware.org/isinfo.php

 

It is free. I don't know if it is any faster.

Share this post


Link to post

Seems to be taking much much much longer than I expected to create the MSI file (it ran overnight, and was still running this morning).

 

Does anyone know of any good (free) programs to create an MSI file?

 

I'm using Inno setup. http://www.jrsoftware.org/isinfo.php

 

It is free. I don't know if it is any faster.

 

I'll give it a try. Can't be any slower than "Visual Studio Installer" which is what I've been using. It seems to get exponentially slower the more files I add. (it was still trying its hardest when I got back from classes).

Share this post


Link to post

Seems to be running much much faster (at least for now). Its estimating 40 minutes to completion.

Share this post


Link to post

ah. nvm. the forum time is not set properly. i'm seeing that post as being at 2:56 and its now 6:52 here. I'll fix that.

Share this post


Link to post

soooo.... maybe 4 or 5 hrs?

 

As of right now, I read 55 minutes remaining. This should put it on schedule to be done at around 8pm MST

Share this post


Link to post

Upload just finished...

 

I'll let you know in an hour or so how things go... :P

 

Will this overwrite all the last version, or should I go and delete those?

Edited by table/cache

Share this post


Link to post

Upload just finished...

 

D'oh! Now I see this just as I reached 27% of the previous version. :P

I'll start downloading the new version instead.

 

I'm thinking as this gets larger and more popular a BitTorrent might be the way to go to save you some bandwidth.

 

Thanks for all this effort, BTW. If no one else has offered yet I get dibs on buying your meal at the breakfast next January!

Share this post


Link to post

Upload just finished...

 

I'll let you know in an hour or so how things go... :P

 

Will this overwrite all the last version, or should I go and delete those?

 

Assuming you put it in the same place, it will just overwrite the old version. I wouldn't recommend uninstalling the old one first, as you might end up messing up mapsource (don't know for sure if it will remove the registry entries that it created).

Share this post


Link to post

I just downloaded the whole maps and installed them but nothing is showing up in mapsource.

 

Is there something special to do that i don't know of ?

 

Thanks for the help!

 

Awesome work...

Share this post


Link to post

I just downloaded the whole maps and installed them but nothing is showing up in mapsource.

 

Is there something special to do that i don't know of ?

 

Thanks for the help!

 

Awesome work...

 

Have you looked in the pulldown at top left, just under the File Edit Find menus? There should be a listing for Ibycus Topo 1.1

Share this post


Link to post

Even thought he final option sounds like the most work, I think that is the one I would like. I certainly like hovering over an object to see what it is, but the searchability would also be a nice bonus. If I had to choose on over the other, I would go for the searchability I guess.

 

Looking for opinions...

Those of you who have downloaded the dataset may have noticed that in many cases, things like lakes, streams, rivers etc are nameless as an entity, but have an additional POI overlayed on top of them with what the lake/river/stream/etc is actually called.

 

--------

 

Final option... Do both. Leave the POIs in there, but attempt to properly associate a label with the right river/lake/stream etc.

 

Advantage: Searchable, also you can hover over any point in the associated object and get the name, mapsource will label it, and angle text appropriately etc.

 

Disadvantage: Double labeling. This might be mitigated somewhat by changing the zoom levels around a bit (so that you'll only see the POI label at high zoom), but in essence all the old labeling will stay there, you just now have more to contend with.

 

Thoughts?

Share this post


Link to post
I just downloaded the whole maps and installed them but nothing is showing up in mapsource.

 

Is there something special to do that i don't know of ?

 

Thanks for the help!

 

Awesome work...

Nope it was automaticly listed for me.

00000000000fl9.jpg

Share this post


Link to post

when I am zoomed way out I see where the maps should be, whenI try to go in to view them they disappear, very sad really.

 

thanks for all the work you put into this.

 

Bryan

Share this post


Link to post

I just downloaded the whole maps and installed them but nothing is showing up in mapsource.

 

Is there something special to do that i don't know of ?

 

Thanks for the help!

 

Awesome work...

 

I take it you downloaded the new version? Nothing's in the drop down list?

 

If that is the case, it sounds like the registry settings are getting added with this new version of the installer. How comfortable are you navigating the registry? (Don't add or delete anything, just want you to check what's in there).

 

There should be a key under HKLM\Software\Garmin\Mapsource\Products called NTDB Data.

 

If you aren't comfortable, I can always put together a reg file for you to add this in (assuming you accepted the default installation location).

Share this post


Link to post

when I am zoomed way out I see where the maps should be, whenI try to go in to view them they disappear, very sad really.

 

thanks for all the work you put into this.

 

Bryan

 

Try hitting Control-G (i.e. View->Show GPS map detail.)

 

Due to the complexity of the maps, I have for now left the preview map blank (except for provincial boundaries). Hitting Control-G causes mapsource to read the actual data in the IMG files rather than the preview map.

 

Hope that helps.

 

Dale

Share this post


Link to post

I just downloaded the whole maps and installed them but nothing is showing up in mapsource.

 

Is there something special to do that i don't know of ?

 

Thanks for the help!

 

Awesome work...

 

I take it you downloaded the new version? Nothing's in the drop down list?

 

If that is the case, it sounds like the registry settings are getting added with this new version of the installer. How comfortable are you navigating the registry? (Don't add or delete anything, just want you to check what's in there).

 

There should be a key under HKLM\Software\Garmin\Mapsource\Products called NTDB Data.

 

If you aren't comfortable, I can always put together a reg file for you to add this in (assuming you accepted the default installation location).

 

Oh crumb....

 

Just retested my installer, and it looks like it isn't properly creating the registry entries in the new version (which is why it doesn't show up in mapsource). I'll post a .reg file shortly that will work if you installed to c:\program files\topomaps (otherwise you'll have to edit the file).

 

Dale

Share this post


Link to post

Just found out the installer I created seems to be very broken. It worked for me because I already had everything I needed in place. It seems to be installing things in locations other than where I would have expected them, and not creating the registry entries it should.

 

I'm going to take this version offline until I can fix it.

 

For those of you who have already downloaded the file, you can fix it yourself as follows:

 

1. In the program directory, you will see a whole bunch of files called ########.img (where # represents a digit from 0-->9). Create a new directory called IMGs and move these files in to it (if you have the old version installed, overwrite any existing files)

2. If you only have the old version, you'll also have to create the appropriate registry entries. If you installed to c:\program files\topomaps, this file should create them for you http://www.ibycus.com/ibycustopo/regfix.reg . NOTE IF YOU INSTALLED ANYWHERE ELSE, THIS FILE WILL CORRUPT YOUR MAPSOURCE INSTALLATION. IT IS RECOVERABLE (BY DELETING THE NEW ENTRIES), BUT IT CAN BE VERY SCARY.

 

I've got three midterms today, so I probably won't be able to get a new version out until sometime tomorrow, or even the next day.

Share this post


Link to post

So I downloaded and installed the apperently broken version last night. Having a look at the 082 maps, it appeared that there were no prolems fixed, and I assumed that I had misunderstood that it was an update.

 

Now it seems that the installer was broken? This is "good" news perhaps.

 

I tried the fix above, but it seems the .img files do not allow me to move them. ----- I had to be logged in as an Admin to move those files.

 

When I did, MapSource complained that it could not find NTDBData.img, and would shutdown immediately...

 

Now it has a reg problem, and I have removed and reinstalled it to no avail... :P Guess I need to try the regfix file?

 

:/

Edited by table/cache

Share this post


Link to post

So I downloaded and installed the apperently broken version last night. Having a look at the 082 maps, it appeared that there were no prolems fixed, and I assumed that I had misunderstood that it was an update.

 

Now it seems that the installer was broken? This is "good" news perhaps.

 

I tried the fix above, but it seems the .img files do not allow me to move them. ----- I had to be logged in as an Admin to move those files.

 

When I did, MapSource complained that it could not find NTDBData.img, and would shutdown immediately...

 

Now it has a reg problem, and I have removed and reinstalled it to no avail... :) Guess I need to try the regfix file?

 

:/

 

typing on pda...must be brief.

 

Problem is you moved NTDBData.img along with the numbered IMGs.

Move NTDBData.img back to original directory, and it should fix your problem. (regfix.reg won't fix problem)

Share this post


Link to post

good luck on your mid terms.

 

Bryan

 

Thanks :). Two down, one left to go. (I've written ECON and PSYC, I have introduction to computers left).

 

Anyways, back to table/cache's problem. I'm not sure why you wouldn't be allowed to move the IMG files. Was mapsource open while you were doing this?

 

Have you tried the above solution (put NTDBData.img back in to c:\program files\topomaps)?

 

It might be illuminating to give all those who unfortunately downloaded the old 'update' before the problems were fixed.

 

A mapsource mapset like this has essentially three main components.

 

1. The map files themselves. This is what gets sent to your GPS when you send them to your GPS (its where the actual data is)

2. The index map. This is the file with the TDB extension. It contains references to each map file that is part of the mapset. It is generally quite small.

3. The 'preview' image. This contains what you see in mapsource when you have "Show GPS map detail" turned off. It contains the boundaries of each mapsheet, and any background basemap information (in the case of my maps, it simply contains the outline of each of the provinces. It has the same name as the TDB file, but with an IMG extension.

 

The above three 'objects' need to be correctly referenced in the registry. They need to be listed in HKEY_LOCAL_MACHINE\Software\Garmin\Mapsource\Products .

 

Then you have a subkey of that named "NTDBData", this is the product name (sometimes this can be a number). That subkey contains three values (or it should)

LOC -- This is the path to the map files (IMG files) for this product. In the case of my maps, the default is c:\program files\topomaps\imgs

BMAP --- This is the path to the Background Map file. This is the NTDBData.img file. The default is c:\program files\topomaps\NTDBData.img

TDB --- Path to TDB file (C:\program files\topomaps\NTDBData.TDB

 

There were two bugs in the version I put up yesterday:

 

1. The registry values weren't created --- This is fixed by the regfix.reg file.

2. The IMG files were put in the wrong place. --- They were initially installed to c:\program files\topomaps.

 

#1 means that if you didn't have the old version on, you'll install the new one, and the map won't show up in mapsource.

#2 means that if you had the old version, and installed the new one, the new IMG files will be in the wrong location. So won't be seen by mapsource (again nothing will happen after the install).

 

To correct my mistake, you have to move the numbered image files (leave NTDBData.img) to a subfolder called IMGs, and if this is a fresh install, you'll also have to run the regfix file.

 

Users of the old version should not need the regfix file, as the registry entries should already be in place from the old version.

 

Hope that clears things up a bit, and sorry for the hassles. I really should have tested this more carefully before I put it up.

Share this post


Link to post

Even thought he final option sounds like the most work, I think that is the one I would like. I certainly like hovering over an object to see what it is, but the searchability would also be a nice bonus. If I had to choose on over the other, I would go for the searchability I guess.

 

Actually, the final option isn't really any more difficult than option 2 (give or take a line or two of code).

 

More opinions?

Share this post


Link to post

OK, I should have been studying... anyways I've set the new version uploading. It will be available at http://www.ibycus.com/ibycustopo/TopoMaps.exe in about 3 hours (~1pm MST)

 

This link is now live. I wasn't able to do as much testing as I would have liked though due to those pesky midterm thingys. I'll be testing it out tonight.

Share this post


Link to post

Hello Ibycus,

 

The only file i installed was the second one; (Topo map 11. 658 mb), not the first one.

 

I really know how to use mapsource, i've been using it for a long time, but i have never played in the registry, i don't feel comfortable doing so.

 

Would it be a good idea if i just uninstall the broken mapset and just install the new healthy one.

 

By the way, thanks alot Ibycus for your help, I can't wait to see your maps

in my mapsource.

Share this post


Link to post

you've spoiled me now I am jonesing for 41, 42.

 

by the way has anyone mentioned how bloody awesome this is?

 

Bryan

Share this post


Link to post

Ibycus:

 

Here's the final results of my adventures...

 

I had trouble moving the img files when logged in as a user, when logged in as an administrator they went with no hitches.

 

Somewhere along the way I must have messed up the NTDBData.img file, and that somehow seems to have led to other problems that eventually prevented Mapsource from launching.

 

I eventually solved it all by going back to a system restore point from before I started all this, and redoing all the installs with the new file you uploaded this morning.

 

Final result:

 

Everything is working again, and I have all of Southern AB and BC on my GPSr. :)

 

They look GOOD! Elevations seem to be fixed, a few sheets seem to be missing again.

 

There seem to be some issues again with the ski lifts at Granite Mountain and Red Mountain on 082F04. There is one with a stream that runs under it, and at certain zoom levels (200m and 300m on my Garmin 60CSx) the stream overlays the lift (marked as a powerline - but we've been over that) and obscures it. I'm not sure if that can be fixed, or if it's neccesary. I notice it too in some places where a pipeline is near a contour line, the countour line "breaks" the pipeline.

 

The road data seems really good, showing lots of little obscure alleys and such.

 

I noticed the ocean comes up as a lake out on the BC coast!

 

Again - a huge thank you!... now get back to studying. :) I am procratinating too, supposed to be doing study for First Aid.

Share this post


Link to post

Hello Ibycus,

 

The only file i installed was the second one; (Topo map 11. 658 mb), not the first one.

 

I really know how to use mapsource, i've been using it for a long time, but i have never played in the registry, i don't feel comfortable doing so.

 

Would it be a good idea if i just uninstall the broken mapset and just install the new healthy one.

 

By the way, thanks alot Ibycus for your help, I can't wait to see your maps

in my mapsource.

 

Assuming things are working OK right now (i.e. you haven't tried to fix the registry yourself) your best bet is to uninstall and reinstall the new one (that of course means another 658mb download). Assuming that isn't a problem for you, yes this should work fine.

 

If things aren't working properly, an uninstall might not fix it, but an install of the new clean version should.

 

HTH,

 

Dale

Share this post


Link to post

Nope it was automaticly listed for me.

00000000000fl9.jpg

 

SOMEbody has a whole lot of ISO files hidden on their computer.

Share this post


Link to post

Nope it was automaticly listed for me.

00000000000fl9.jpg

SOMEbody has a whole lot of ISO files hidden on their computer.
Not really.

00000000000le4.th.jpg

 

More importantly what are the zones currently ready to be downloaded Ibycus?

is 092 ready?

Share this post


Link to post

Ski Hills show the POI icon for waterskiing as opposed to downhill skiing.

 

Ha! Hadn't noticed that. When I pick the entity type, I just have a description to work from. (this one is listed as "skiing".

Strangely, I can't seem to find the correct enity type for 'downhill' skiing.

Share this post


Link to post

Nope it was automaticly listed for me.

00000000000fl9.jpg

SOMEbody has a whole lot of ISO files hidden on their computer.
Not really.

00000000000le4.th.jpg

 

More importantly what are the zones currently ready to be downloaded Ibycus?

is 092 ready?

 

Yep 092 is included in the new download.

 

Some thing I have to find somewhere is some (free) decent bathymetric data. I'd love to make some good marine maps.

Share this post


Link to post
Assuming things are working OK right now (i.e. you haven't tried to fix the registry yourself) your best bet is to uninstall and reinstall the new one (that of course means another 658mb download). Assuming that isn't a problem for you, yes this should work fine.

 

If things aren't working properly, an uninstall might not fix it, but an install of the new clean version should.

 

I uninstalled the old version and installed the new one and everything works fine.

Your maps are awesome.

 

Thanks a million !

Share this post


Link to post

These maps are really nice. Any luck with the minor road names?

 

I live in south eastern Ontario (031) and your latest version has most of 031 but with many holes, especially 031C08, 031C09 and 031C10; right were I live. :)

 

Thank you for your hard work. The colouring alone makes these much nicer than the standard Garmin ones. I look forward to a complete set.

Share this post


Link to post

Ski Hills show the POI icon for waterskiing as opposed to downhill skiing.

 

Ha! Hadn't noticed that. When I pick the entity type, I just have a description to work from. (this one is listed as "skiing".

Strangely, I can't seem to find the correct enity type for 'downhill' skiing.

 

Have you tried "Ski Resort"? It's cofusing because in Mapsource, Waterskiing appears as "Skiing Area" whereas downhill is titled "Ski Resort". The only way to tell the difference is the icon, as the one is clearly waterskiing.

Share this post


Link to post

Ski Hills show the POI icon for waterskiing as opposed to downhill skiing.

 

Ha! Hadn't noticed that. When I pick the entity type, I just have a description to work from. (this one is listed as "skiing".

Strangely, I can't seem to find the correct enity type for 'downhill' skiing.

 

Have you tried "Ski Resort"? It's cofusing because in Mapsource, Waterskiing appears as "Skiing Area" whereas downhill is titled "Ski Resort". The only way to tell the difference is the icon, as the one is clearly waterskiing.

 

I've changed "Ski Jump" to "Slope" and "Ski Centre" to "Ski Resort"

Share this post


Link to post

These maps are really nice. Any luck with the minor road names?

 

I live in south eastern Ontario (031) and your latest version has most of 031 but with many holes, especially 031C08, 031C09 and 031C10; right were I live. :(

 

Thank you for your hard work. The colouring alone makes these much nicer than the standard Garmin ones. I look forward to a complete set.

 

It seems like C08 and 09 were victims of the "TreSize" problem previously mentioned. I've resubmitted them to be compiled with a larger Tre Size. Hopefully this will fix the problem.

 

No idea what happend to C10. It doesn't seem to even have been uploaded. I'll try to remember to check my source files tonight to see if its there.

 

I've also uploaded 032 to be compiled.

Share this post


Link to post

Hey,

 

First off this is an awesome project you have on the go. I've been looking into something to get interested in for a while now and with my recent interest in geocaching this may be something that fits into what i'm looking for. I think I'm going to look into your process to see how you're doing things and try to learn from what you've done. Who knows maybe i'll be able to give you a hand someday if I get that far with it.

 

Secondly, I'm looking forward to getting home tonight and giving the NB section a try, I looked up the dates for it and was rather sad to see it's from 2003. Hopefully they'll update their info soon.

 

Thanks for the great project.

Brad

Share this post


Link to post

Hey,

 

First off this is an awesome project you have on the go. I've been looking into something to get interested in for a while now and with my recent interest in geocaching this may be something that fits into what i'm looking for. I think I'm going to look into your process to see how you're doing things and try to learn from what you've done. Who knows maybe i'll be able to give you a hand someday if I get that far with it.

 

Secondly, I'm looking forward to getting home tonight and giving the NB section a try, I looked up the dates for it and was rather sad to see it's from 2003. Hopefully they'll update their info soon.

 

Thanks for the great project.

Brad

 

I should mention, its only the road data that's from 2003. The rest of the data is from another source. If you can find a more recent (accurate) set of roads (with a license agreement that lets me distribute it) I'm more than willing to look at putting them in.

 

I know there is a more up to date road set available for Ontario (with names), but you have to set up an account on the site with them, and for some reason my e-mail to them isn't going through.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 45

×