Jump to content

Problems with Garmin Legend HCx


grodgers
Followers 0

Recommended Posts

Hi

As I'm fairly new to this group I thought this might be the best place to get an answer to some recent problems I am having with my Garmin Legend HCx.

1. When I updated my software to version 2.40 it seemed to work havoc with my unit.

2. No longer can I acquire satellites even though I o to the Satellite status page and press the 'Menu' button, then Select "New Location", then Select "Automatic" and finally l et the GPS acquire for about 15 minutes, stationary, with a clear view of the sky.

3. The date on the unit remains at the 28th September 2007 and the time is shown as 15.35, the time I did the update yesterday.

4. I though a hard reset might solve the problem but no.

Would anyone have anymore suggestions as I was wanting to use my unit on the hiking/rambling trip tomorrow?

Thanks,

Gerald

Link to comment

Hi

As I'm fairly new to this group I thought this might be the best place to get an answer to some recent problems I am having with my Garmin Legend HCx.

1. When I updated my software to version 2.40 it seemed to work havoc with my unit.

2. No longer can I acquire satellites even though I o to the Satellite status page and press the 'Menu' button, then Select "New Location", then Select "Automatic" and finally l et the GPS acquire for about 15 minutes, stationary, with a clear view of the sky.

3. The date on the unit remains at the 28th September 2007 and the time is shown as 15.35, the time I did the update yesterday.

4. I though a hard reset might solve the problem but no.

Would anyone have anymore suggestions as I was wanting to use my unit on the hiking/rambling trip tomorrow?

Thanks,

Gerald

The GPS has two sets of software--the system software and the chipset or GPS software. Given that you just updated your system software to 2.40, you probably need to update the chipset software as well. Those symptoms are common for a chipset software failure and updating or reinstalling the chipset software typically fixes it. You should be able to use the WebUpdater to check for chipset updates (even if you already did it, try it again). For the Vista HCx, and I assume also the Legend HCx, the current version of chipset software is 2.30. If that fails, you can try the hard reset option (search this forums for details).

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 0
×
×
  • Create New...