Jump to content

'Caches Along a Route' Problem


imajeep

Recommended Posts

I have a bad route on my 'Your Created Routes' page. The route is empty, and the map for the route is of Seattle, instead of Chicago to Milwaukee. I can't delete the route, and I can't rename it. Is there any workaround that will allow me to deep-six this route? Thanks.

Link to post

I also get the custom route showing the greater Seattle area, with no route line superimposed on the map.

 

There's also something strange with my custom routes: I tried to upload a custom route and got a web page with a server error message. So I went back, hit refresh, and tried again. Long story short... I've got three copies of the same custom route shown and I can't delete a single one of them.

Link to post

I also have this issue with some routes. If I try to create a PQ with the data it gives me an exception that makes me think there was an issue with the route uploaded or the backend processing of the gpx failed and is basically a null array. It does create the shell of a PQ which I can delete from the main PQ screen by selecting the Trash Can.

 

here is the stack:

[invalidOperationException: Queue empty.]

System.Collections.Queue.Dequeue() +110

Groundspeak.Web.UserRoutes.UserRoutePoints.EncodeSignedNumber(Decimal num) +269

Groundspeak.Web.UserRoutes.UserRoutePoints.EncodeLatLong() +339

Geocaching.UI.URQuery.ShowQueryInfo() +713

Geocaching.UI.URQuery.UpdatePocketQuery(Boolean IsNew) +5418

Geocaching.UI.URQuery.btnSubmit_Click(Object sender, EventArgs e) +666

System.Web.UI.WebControls.Button.OnClick(EventArgs e) +108

System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +57

System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +18

System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +33

System.Web.UI.Page.ProcessRequestMain() +1330

 

What is odd is that I do not remember it giving me an exception on upload, although I do remember that it did not show the proper map even when preview was clicked.

 

I also have another route that I created about a week ago that seemed to go weird after upload. Instead of it showing the proper end point of the route it continued several hundred miles east to an arbitrary point in the middle of the Atlantic.

 

I would be more interested in finding the root cause of these, and if it is something on our end versus just having an easy way to delete them. I really would like to be able to have confidence in my exports and this valuable service.

 

By the way I use Delorme Street Atlas 2006 plus to create my routes then convert them to gpx via gpsbabel.

Edited by renruts
Link to post

I have had the same problems. The caching along a route system seams to be very sensative, if I create a route using MapSource and then create a GPX from that it almost always fails, if I create it manually using ExpertGPS (by hand over the topo map) it works most of the time. I hope TPTB have focused some of there engineering resources on this problem.

Link to post

Well I tried creating a route in Google Earth and saved it both as a .kmz file as well as a .kml file. When I first go to upload the route on the Geocaching web site it loads and shows the distance and number of turns just fine.

 

Then you go in to make a Pocket Query and no luck, it shows the mileage of the route but then ZERO turns.

 

Still completely unable to delete these added routes. I now have five of them showing on my Find Caches Along A Route page and no way to get rid of them.

 

Hope this bug is ironed out soon! :rolleyes:

Link to post
Guest
This topic is now closed to further replies.
×
×
  • Create New...