Jump to content

Garmin Etrex Legend CX


judygrant
Followers 1

Recommended Posts

I am still unable to get the compass page to come up. I do a cache using 'follow the road' then go back to 'find' and tell it 'off the road' when the location has been reached. I still can't get the compass page to appear to help us go on the paths, woods to locate it closer.

 

Any help would really be appreciated. I am trying to help my sister and leaving Nova Scotia Monday July 16th. would love to be able to show her how to find at least one cache before I leave her with the GPS<

 

thanks so much.

Link to comment

I may have had a similar problem with my Etrex Venture CX. My GPS worked fine using firmware 2.6, so being the trusting person that I am...I downloaded the newest v2.7 . When I went caching, picked a waypoint and "GOTO"...the menu was locked, could not cycle through all my views, namely the compass screen. I reverted back to v2.6 and I'm back in business, no big deal since I never had any problems before. One final important notice before you do this.....back up all your waypoints using something like EasyGPS or similar software. I LOST ALL MY WAYPOINTS WHEN I REVERTED ! Oh well, at least it works now. Hope this helps.

 

Hawk_Eyes0608

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 1
×
×
  • Create New...