Jump to content

Garmin eTrex Vista Cx Connectivity Problem - PLEASE HELP!

Followers 1

Recommended Posts

Worked fine yesterday. Won't today. Don't know what I did.


The unit will shut down when I connect it to the USB power. It will not start up if connected to USB power. Runs fine using the batteries. I may have messed around with something in the GPSr, but I don't know what.


Unit will function even if USB cord is attached to unit, as long as it is not plugged into the computer. Tried on both Mac & PC to see if it was the computer. It will not work on either.


I've got the latest firmware in there (v2.70), tried doing a hard reset, is NOT in demo mode.


Please help!

Edited by Isaiah 40:31
Link to comment

Yeah I emailed Tech Support and he gave me RMA # so I could send it back. So about a week later (today) they sent me a brand new unit. I’ve been playing with it all evening with it connected to my laptop. I haven’t had a problem with it. but the real test will be this weekend at a Event Cache. :ph34r:

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Followers 1
  • Create New...