Jump to content

GSAK Won't Talk to Garmin 76 Series


Recommended Posts

When I try to upload or download waypoints from GSAK to my GPSMAP 76CSx from GSAK, a "sending waypoints" or "receiving waypoints" dialog box comes up with a gas gauge that goes from empty to full over and over and over and over and over, ad infinitem. It seems like it isn't communicating with the GPSr at all. USB connection. I can upload and download fine with Mapsource. The only way to get GSAK to do anything is to end task in task manager. Help!

Link to comment

I recently had the same problem with GSAK when I tried to download waypoints to my new Venture CX (a USB connection). I solved the problem by getting the latest version (6.6.4, build 20) of GSAK, which includes an updated version of GPSbabel.


You didn't mention which version of GSAK you are using and which OS your computer uses. If your OS is Windows 98 or Windows ME, the version of the GPSbabel program (which actually does the output to the GPS) included in the latest GSAK package has a fix for the "Windows 98 & Windows ME freeze problem". The fix can be activated via the "advanced " tab in GSAK's tools.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...