Jump to content

Getting Google Maps Key Error


DeadParrot
Followers 1

Recommended Posts

I have identified something very strange on the geocaching site. When a friend sends me a link to a cache page, I open the link and the page is displayed, I then log in and get a Google Map Key error.

 

Here is the error that is displayed in a popup windows:

 

The Google Maps API key on this website was registered for a different web site. You can generate a new key for this web site at http://www.google.com/apis/maps/.

 

I did a view source on the page and searched for maps.google.com and noticed that it is there alot, but the page does not display any google maps.

 

Is anyone else experiencing this or have any ideas how to fix it?

 

DeadParrot

Edited by DeadParrot
Link to comment

It's a known issue. What's happening is that there are two slashes (//) after www.geocaching.com that's screwing up the URL. If you take out one of the slashes, you'll have no problem when you open the cache's page.

 

The url I am using does not have two slashes (//) at the end and that is NOT what is causing the google map key error.

 

Here is how I am able to reproduce the errror:

 

1. Logged Off, open a link to a cache page (Like http://www.geocaching.com/seek/cache_detai...f-09e51705735b)

2. One the page has loaded log in by clicking the log in link in the upper right corner of the screen.

3. Once you return to the page the error is displayed.

 

This does not happen on all pages. When it does happen it may happens and I refresh the page it continues to happen until I close the browser and go back to the cache page. At this point the error does not display and never displays again.

 

I really think this is an issue with the key in the page for Google Maps. That is what the error message points to. It seems as if pages created on a development server with a different Google Map Key were moved to a production server and the Key didn't get updated. Yes, I am an IS Professional :D and I realize my geek is showing.

 

I have also consulted with others at my location and they usually do not get the error on the same page I do, So I have eliminated our office systems as the issue. I have also walked them through the procedure above on a page that resulted in the error and they also experienced the issue. I have also tried this at home with the same results.

 

Hope the additional information helps.

Link to comment

I had the same Error quote that you did get, and since then I didn't get any of the new Google-maps at all on the Geocaching sites but the old maps from mapquest. Thats a pity, the new way was much easier for me to find caches on places where I am willing to go (sorry about my English, I hope you will understand, what I mean). Because I am only a user with nearly no computer knowledge :P I hope the problem will be okay in near future - without my help!

Link to comment
Guest
This topic is now closed to further replies.
Followers 1
×
×
  • Create New...