Jump to content

Etrex Legend Computer Connection

Recommended Posts

Questions: What operating system are you using? What GPSr are you using? What software are you trying to connect? Without knowing these answers, start by making sure your computer has the latest USB drivers installed. Restart your computer after installing the drivers. Make sure your GPSr and your computer have the same baud rate, port settings (8/N/1), compatible NMEA settings for the software.


I'm sure if you supply answers to the above questions, you'll solve the problem in no time.

Link to comment

Aside from answering all the relevant questions above, you should also know that some USB to serial adapters have fits trying to talk to GPSr's, but others work fine. I had to try new drivers for my USB to serial adapter and monkey with which port it used before I got it to work. I solved the problem by getting a PCMCIA seril port card off of ebay for about $30. It's much more reliable than the USB to serial adapter I have. Anyway, answer the previously posted questions and we'll help if we can.


edit: can't type

Edited by DocDiTTo
Link to comment

What I found as a simple work around with a USB/serial adapter is to plug the device on the cable, turn it on, THEN reboot the computer with it plugged in. For whatever reason, the pretend USB device likes it better, that technique has worked for my Legend -USB adapter connection since I have had it. Good luck.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...