Sign in to follow this  
Followers 8
Shorelander

Bugs In The Machine

137 posts in this topic

I figured this would be useful to get the issues out on the table. This isn't for feature requests, but for known problems.

 

I have seen a few:

  • Logs I have no longer show a check mark, and furthermore, on the "last visited" view from the category level, show "not yet"
  • Where is the Massachusetts Historic Plaques category in the directory? Is the directory still undergoing changes? It says Directory > MHP, but I don't see it in the root level.
  • The "requirements for logging" section does not acknowledge carriage returns. Also, the checkbox in the "edit category" page that says "If descriptions below are html, check this box" would seem to apply to not just the "please define" textbox but the boxes below it - yet those lower boxes don't recognize HTML.

OK, I guess that didn't deserve a bulleted list, but I presume more issues will creep out as time progresses. Thanks, BTW - the upgrades seem to be pretty neat and for the most part functional!

 

SLer

 

Edit: And, to be totally nitpicky, renovated has only one 'n' (in re the update announcement).

Edited by Shorelander
0

Share this post


Link to post

Where is the Massachusetts Historic Plaques category in the directory? Is the directory still undergoing changes? It says Directory > MHP, but I don't see it in the root level.

I was about to post regarding Historic Markers. There are now 20 or so Historic Marker categories; collectively, they make up the single most active segment of Waymarking at this time. But all of them seem to have been omitted from the new directory structure. Instead they are individual orphaned categories off the main directory. They don't even show up on the page organized by subject matter.

 

Because of the number of subcategories, I would submit that a separate "Historic Markers" main category is justified, alongside "Animals," "Buildings," etc. Please return the popular historic marker categories to the directory. Thanks.

0

Share this post


Link to post

I put it in "History/Culture" for now. We'll work on ways for boosting traffic to the more active categories in the future.

0

Share this post


Link to post

Additional problem, perhaps intentional, perhaps not: Unapproved waymarks (at least, one of mine) appear in the KML file. (Case: Alphabet Zoo in Winchester, MA, in the Playgrounds category).

 

SLer

0

Share this post


Link to post

Insignificant bug:

 

Clicking on the ? (Help) on the My Favorites tab brings up a help window describing the Newest Categories tab (Help=Honeymoon).

0

Share this post


Link to post

A few notes on new software. Not sure if this was intentional or not:

 

Red check mark next to waymarks visited isn't appearing. This isn't helping me keep track of waymarks I haven't yet visited,

 

On Stats page, when you click the number of visited waymarks in a category, it doesn't show all of my visits as before. Instead, a red message: "There are no records within 10 miles of the location you selected" appears. Then under "Waymark search," the default goes to all waymarks, not the category.

 

I like to feature where images are added by default to the waymark page.

 

-showbizkid

0

Share this post


Link to post

Additional problem, perhaps intentional, perhaps not: Unapproved waymarks (at least, one of mine) appear in the KML file. (Case: Alphabet Zoo in Winchester, MA, in the Playgrounds category).

 

SLer

Nice feature, if it's not considered to be a bug. You can use this to see how far behind a category manager is with their approval queue.

 

Actually, you don't even need to get to the KML file to see the backup - you can just compare the count of Waymarks on the category page with the count shown on the My Favorites tab.

0

Share this post


Link to post

On 3/30 I tried to upload images to the waymark gallery and kept getting a "Denied" message (Virtual Directory cannot be listed). I did get some uploaded today. The waymark is Kitt Peak National Observatory under the Astronomical Observatories category. Also, in the waymark galley there are the images thumbnails, but when you click on a thumbnail to see the larger image...the larger image is not shown. All that is shown is the image caption and the links to the waymark and the parent category. Is the "File Description" box on the Upload Image screen suppsoed to be HTML enabled so that I need to embed the image in this area (vis a vis the "Long Description" area on the waymark edit page???

 

I like where this site is headed and am promoting it with friends who are into the RV thing and Geocaching about 6 months out of the year.

 

CPT Kelly

Edited by CPT Kelly & MAJ Sandy
0

Share this post


Link to post

On 3/30 I tried to upload images to the waymark gallery and kept getting a "Denied" message (Virtual Directory cannot be listed). I did get some uploaded today. The waymark is Kitt Peak National Observatory under the Astronomical Observatories category. Also, in the waymark galley there are the images thumbnails, but when you click on a thumbnail to see the larger image...the larger image is not shown. All that is shown is the image caption and the links to the waymark and the parent category. Is the "File Description" box on the Upload Image screen suppsoed to be HTML enabled so that I need to embed the image in this area (vis a vis the "Long Description" area on the waymark edit page???

 

I like where this site is headed and am promoting it with friends who are into the RV thing and Geocaching about 6 months out of the year.

 

CPT Kelly

 

CPT Kelly:

 

Just a thought. I learned early on that if you try and give a photo in a specific waymark gallery the same name, you get the Virtual Directory cannot be listed warning. Give photos a different name and they work.

 

showbizkid

0

Share this post


Link to post

Another bug?:

 

In the pre-update days, when you posted a photo to a log, then went to the log, the photo would appear next to the log. Now you only get a thumbnail. Seeing photos (not thumbnails) on log pages is just as important. Many categories require a photo. We should all be able to view these easily, not have to click multiple times.

 

showbizkid

0

Share this post


Link to post

Oversight

 

I cant find a way of mailing regular members of a group. Had to do it by searching for them by name.

0

Share this post


Link to post

Showbizkid,

 

Thanks for the info. We'll try and do that in the future. That's exactly what I was doing!

 

CPT Kelly

0

Share this post


Link to post

New bug or maybe I am missing something,

 

On the group details page it shows who the officers are and who members are.

 

example here

 

In the upper right corner there is the group ranks button that takes you to a page that allows you to edit the officers titles, position on the list and permissions. Because of his support from the get go I wanted to edit more capabilities for Volcanoguy and move him to the second position on the list. I was able to update the title on my line but the #2 and #3 spots remain the same on the group details page even though I edited it on the group rank page like this.

 

Oregon Pioneer 1 Can Edit Category

Can Edit Content

Can Edit Logo

Can Invite New Members

Can Review Waymarks

Can Create Annoucements

 

Oregon Native 2 Can Edit Content

Can Edit Logo

Can Invite New Members

Can Review Waymarks

Can Create Annoucements

 

Officer 2 3 Can Invite New Members

Can Review Waymarks

 

B)

0

Share this post


Link to post

There are actually two steps to that process. One involves creating the rank (which you did), and the other involves changing VolcanoGuy's rank. Click his name in your officer list and then click the "change rank" link on the member details page. Then you can select the appropriate rank in the dropdown list.

 

-nate

0

Share this post


Link to post

I noticed a typo...

 

On the right hand side, when viewing a groups details, you have a link called "Group Details" in white, with black letters.

 

When you hover your pointer over the link, it turns red with white letters, and is labeled "Group Detalis" - I thought I was seeing things at first.

0

Share this post


Link to post

There are actually two steps to that process. One involves creating the rank (which you did), and the other involves changing VolcanoGuy's rank. Click his name in your officer list and then click the "change rank" link on the member details page. Then you can select the appropriate rank in the dropdown list.

 

-nate

 

Thanks that was it.

0

Share this post


Link to post

PA Historical markers not showing when i search for All Waymarks

I have to go to largest waymark catagory to find them.

They aren't showing in Historical markers too.

:(:(;):(:(

0

Share this post


Link to post

I think the popularity filter may be at work there, SAWKS. If premium members like that category, I encourage them to vote to "upgrade" PA Historic Markers so that regular members can see it. Before the popularity votes got re-set last week, this category was in the top 10% for popularity. That would seem to make sense, as it is the second largest category after benchmarks.

0

Share this post


Link to post

Try it now. The filter has been adjusted for non-premium members.

0

Share this post


Link to post

so lets see if i got all this straight....

 

where do i get the kml for Waymarking? i barely can use the one for caching--i cant get online with my pc, i am at a gov workstation and dont know if i can put it on here......

 

so the votes being reset means i have to start voting all over again?

 

i liked the large pic next to the log...and i hate that not yet approved mark visits do not accept uploads--if i KNOW the mark will be approved, i go ahead and visit it, putting my pics in the log (a creation visit) so that they might one day be in 'my gallery'.

 

along these lines, pre update logging marks in this manner would auto add to your stats...but what if it has to be archived due to being in the wrong category (not a fountain, but a former fountain). i think that it should not be in the 'waymarks visited' stats until it has been approved.

this brings me to the point that "i own 610 waymarks", but approximately 4 of that # is archived marks that did not go into a category (denied for valid reasons, but it has nowhere to go). can we do something with these? until now, i was the only one who knew that this was affecting my #s--but believe me, 'it isnt any skin off my back'.

0

Share this post


Link to post

oh yea, the red check marks...

why cant we have the 'owner' arrow from caching for 'our marks' and the checks for the visited ones? they will appear on the map as checked boxes too (at least for PMs?)

 

you do know that you can visit a mark as many times as you want, but only the first log will change your stats...so if you go someplace on vacation every year or something

0

Share this post


Link to post

Found a bug. I got an email notification for one of my waymarks. The links on it dont work. I checked other email notifications. They also have the same bugs in the links.

 

The email:

 

This is an automated message from Waymarking.com

 

You are receiving this email because you are the owner of the RotorWay

International waymark.

 

ClanCampbellChandler visited RotorWay International on 4/3/2006

4:53:45 PM and posted the following comments:

 

"Easy driveup...used to pay my Cox bill nearby..."

 

Visit this log entry at the following address:

http://www.Waymarking.com/logs/log_details...type=2&bname=my

home&LogGUID=cf65bcf5-bd8f-45d3-acf5-5ad941a637ac

 

Visit the 'RotorWay International ' waymark at the following address:

http://www.Waymarking.com/waymarks/details...type=2&bname=my

home&WMGUID=40d431a1-e1e7-462f-ba8c-d33afc3c9bcc

 

The owner of this log will have one hour from the time of the initial

posting to edit this log. After this hour has expired, the posted log

will no longer be editable.

0

Share this post


Link to post

Try it now. The filter has been adjusted for non-premium members.

When logged in under a permitted non-premium account that I own, I still cannot see the Pennsylvania Historic Markers category. In the directory, a message continues to say that additional categories are hidden due to the popularity filter.

 

Can you explain in more detail what was changed, what the new settings are, and any action that a non-premium member needs to take in order to view categories like this one when searching based on location, searching by postal code, looking in the main directory view, etc.?

0

Share this post


Link to post

I checked on categories for review, and 2 new categories popped up - Michigan Historical Markers and Civil Defense Shelters (or something similar). When I try to click on the link to view the category details, it says I've already voted for that category - but I haven't voted on either one yet.

0

Share this post


Link to post

I checked on categories for review, and 2 new categories popped up - Michigan Historical Markers and Civil Defense Shelters (or something similar). When I try to click on the link to view the category details, it says I've already voted for that category - but I haven't voted on either one yet.

 

You're not alone - I get the same thing too :anibad:

0

Share this post


Link to post

I checked on categories for review, and 2 new categories popped up - Michigan Historical Markers and Civil Defense Shelters (or something similar). When I try to click on the link to view the category details, it says I've already voted for that category - but I haven't voted on either one yet.

I voted thumbs-up on Michigan Historic Markers earlier in the day. When I returned to check just now, that one was gone from the list of categories for me to review, but Civil Defense Shelters was there. When I opened that one up, I got the same erroneous message that Henki reported.

Edited by The Leprechauns
0

Share this post


Link to post

I checked on categories for review, and 2 new categories popped up - Michigan Historical Markers and Civil Defense Shelters (or something similar). When I try to click on the link to view the category details, it says I've already voted for that category - but I haven't voted on either one yet.

 

This was a bug that was introduced yesterday accidentally, but is now working properly. Sorry about the inconvenience.

0

Share this post


Link to post

I have a variable that I would like to get rid of. I don't know what will happen to the information if I archive it and I would hate to lose 78 waymarks :ph34r: worth of information that has been added to a text box. What I want to do and have discussed with the primary contributor to the category is to add the text to the long description of each of the waymarks and I would like to get started on that before it is much more populated. I went in to edit one of my waymarks in the category and I cannot edit the long description to add the text that I am transferring from the variable "Marker Text". I tried to delete information from the long description as well and was unable to edit it that way as well. So are these locked in some way? It also appears that text may not be showing up in the long description for new waymarks as this new waymark suggests. Volcanoguy didn't add the text into the variable (He added it to the text box since my original post here), I am guessing because of our discussion about moving it to the long description and there is no text to be seen. Perhaps he hasn't added it yet but based on the other issue I am seeing I think we are unable to add it at this point.

:(

 

Thanks.

 

edited to get rid of extra text and clarify.

Edited by TheBeanTeam
0

Share this post


Link to post

So I just went and added a waymark and edited another one and they seem to be OK now. Odd.

But the original one I mentioned still is not editable and gives a "file empty, try another message after an attempt to edit.

Edited by TheBeanTeam
0

Share this post


Link to post

A waymark was just submitted to the Grave of a Famous Person category, and it somehow went directly into an approved state. The approval page indicates that the waymark was approved by the person who submitted it, who is not a member of the group. :ph34r:

 

Auto approval is NOT turned on, and the other waymarks which have been submitted to this category so far required me to approve them before they were listed.

 

I would have approved this particular waymark anyway, but it should not have gone directly to approval.

 

The waymark, in case you need to know, is WM9Z2.

0

Share this post


Link to post

Not sure if this is a bug or a feature :ph34r:

 

My usual practice with geocache page submissions is to leave the cache inactive until I've made sure the page is correct and the links work etc. My understanding is that it only goes for approval when the cache is made active. With a new waymark submission it is working differently. Just submitted one and left it inactive until I'd checked the links and added an image. Surprisingly when I made it active I found it had already been approved - several minutes before I'd finished editing it. Now that is impressive by geocaching standards but probably not the way it should work. I'm guessing that the email notification is going out as soon as the page is first submitted whether or not the active box is checked.

0

Share this post


Link to post

Not sure if this is a bug or a feature :ph34r:

 

My usual practice with geocache page submissions is to leave the cache inactive until I've made sure the page is correct and the links work etc. My understanding is that it only goes for approval when the cache is made active. With a new waymark submission it is working differently. Just submitted one and left it inactive until I'd checked the links and added an image. Surprisingly when I made it active I found it had already been approved - several minutes before I'd finished editing it. Now that is impressive by geocaching standards but probably not the way it should work. I'm guessing that the email notification is going out as soon as the page is first submitted whether or not the active box is checked.

Are you talking about your Grave of a Famous Person waymark?

 

See the post above yours. :(

0

Share this post


Link to post

A waymark was just submitted to the Grave of a Famous Person category, and it somehow went directly into an approved state. The approval page indicates that the waymark was approved by the person who submitted it, who is not a member of the group. :(

 

Auto approval is NOT turned on, and the other waymarks which have been submitted to this category so far required me to approve them before they were listed.

 

I would have approved this particular waymark anyway, but it should not have gone directly to approval.

 

The waymark, in case you need to know, is WM9Z2.

 

That's clever - see my post above on what appeared to happen from my end - definitely a bug in there somewhere and I did see a file empty message while I was editing so maybe that is something to do with it..

 

Note added: For the record the email confirmation arrived at 9:26 PM local time, the approval confirmation arrived at 9:29 PM and I finished the editing, made the waymark active and hit submit at about 9:40 PM :ph34r:

Edited by Hard Oiler
0

Share this post


Link to post

Just submitted one and left it inactive until I'd checked the links and added an image. Surprisingly when I made it active I found it had already been approved - several minutes before I'd finished editing it. I am guessing that the email notification is going out as soon as the page is first submitted whether or not the active box is checked.

If it's the same one that came into my mailbox, a 'hairtrigger finger approval' took place because when I looked at your submission it was already 'Approved'

This is one reason I will 'NEVER' approve a submission unless it has been sitting for 2 days or the 'Category' owner asks for assistance. (certainly not if I am #3 or #4 etc.)

This is the primary reason I never liked the idea of others approving waymark submissions in my (ours now?) category, unless they were asked to do so or in case of a posted absence.

 

BTW....One night I was approving a stack of waymarks submitted by 'thebluequasar' when he wrote me to slow down as he hadn't even finished the last one yet :ph34r:

(..and I do read each and every one of them and check out the links if any)

 

Edit...checked the above link...it wasn't the one I meant. It was this one.

Edited by Jake39
0

Share this post


Link to post

A waymark was just submitted to the Grave of a Famous Person category, and it somehow went directly into an approved state. The approval page indicates that the waymark was approved by the person who submitted it, who is not a member of the group. :unsure:

 

Auto approval is NOT turned on, and the other waymarks which have been submitted to this category so far required me to approve them before they were listed.

 

I would have approved this particular waymark anyway, but it should not have gone directly to approval.

 

The waymark, in case you need to know, is WM9Z2.

 

That's clever - see my post above on what appeared to happen from my end - definitely a bug in there somewhere and I did see a file empty message while I was editing so maybe that is something to do with it..

 

Note added: For the record the email confirmation arrived at 9:26 PM local time, the approval confirmation arrived at 9:29 PM and I finished the editing, made the waymark active and hit submit at about 9:40 PM :unsure:

I've had other submissions to the category since yours got autoapproved last night, and they behaved correctly (they did NOT get automatically approved).

 

So at this point, I'm thinking the bug might be that if someone marks a waymark as inactive and then submits it, that the waymark goes directly through to an approved state.

0

Share this post


Link to post

So I just went and added a waymark and edited another one and they seem to be OK now. Odd.

But the original one I mentioned still is not editable and gives a "file empty, try another message after an attempt to edit.

 

Is there a chance that one of your group members approved the waymark? You may want to check with them first. Each officer is sent an email when a waymark is submitted. There are plans to create rules for who receives what emails in the future, but as things stand right now, all officers are able to review waymarks.

0

Share this post


Link to post

So I just went and added a waymark and edited another one and they seem to be OK now. Odd.

But the original one I mentioned still is not editable and gives a "file empty, try another message after an attempt to edit.

 

Is there a chance that one of your group members approved the waymark? You may want to check with them first. Each officer is sent an email when a waymark is submitted. There are plans to create rules for who receives what emails in the future, but as things stand right now, all officers are able to review waymarks.

 

No it isn't that. This is with waymarks that have been created for some time mostly. I have a variable that uses a large text box called Marker Text. I want to eliminate that variable so I requested those who have created waymarks in the category (Oregon Historic Markers) to move the text from that box into the Long Description box. In the example I gave above, the waymark that is not allowing an edit is mine and approved by me prior to group management. It will not allow an edit of the Long Description at all.

 

I discussed this with a fellow waymarker as well and I will quote him and what he experienced while trying to do the same thing with his waymarks in the category.

 

"There is a problem when editing (empty file error). I've been able to make the edits but it seems to be some kink of conflict between using html in the long description and the automatic photo box. Like I said I was able to make an initial edit to about a third of my waymarks but if I made any error in the initial edit I've not been able to go back and make a second edit, it just keeps the first edit."

0

Share this post


Link to post

Another bug I found - I submitted a Civil War monument, then later edited it. Since it has a mandatory picture update, when I updated, it didn't have a picture with it. So when I pushed the update button, up top it said the update had succeeded, but it actually hadn't.

0

Share this post


Link to post

Another minor bug: the Action Required icon appears next to several categories in my "My Categories" list, but when I click on the icon, there are no unapproved waymarks to approve.

 

I suspect this might be happening when someone has done a "Submit without approval" of a waymark - this is what appeared to happen when BruceS and I were running some tests earlier today.

0

Share this post


Link to post

Another bug I found - I submitted a Civil War monument, then later edited it. Since it has a mandatory picture update, when I updated, it didn't have a picture with it. So when I pushed the update button, up top it said the update had succeeded, but it actually hadn't.

Interesting bug. I think your assessment is correct. We're checking this out.

 

Thanks!

0

Share this post


Link to post

I just had a photo bug.

 

For a waymark in places on the national register of historic places, Mesa Journal--Tribune FHA Demonstration Home, the waymark was initially rejected by the software for not having a year listed numerically. Since I had a year of 2002, that didnt make sense to me. I retyped 2002 and resubmitted the waymark. This time the software accepted the waymark, but didnt include the photo I had loaded into the forced photo field. I had to edit the waymark to include the photo.

 

Hope this helps you figure out the bug.

0

Share this post


Link to post

f6558476-639a-4139-a8fa-e31b0a831f20.jpg

 

Why are all of these pages showing up on the bottom of the comments page after peer review? There really is only 1 page of comments. A bug?

0

Share this post


Link to post

I'm getting all kinds of Virtual Directory errors today (and last night too). I'm trying to edit a couple of my existing waymarks in various categories with no luck. Last night I tried to archive a waymark in the NY Historical Markers category, which was never submitted for review, and got the error too.

0

Share this post


Link to post

Hey, is it just me, or are other people not receiving e-mails? Like confirmation e-mails and whatnot.

0

Share this post


Link to post

I found a bug clicking on a 'breadcrumb link' (the links to the larger categories that a waymark is part of).

 

This is what I did:

 

I went to Directory Home > History/Culture > Historic Markers > Massachusetts Historic Markers

 

Then clicked on Fenway Studios.

 

I then went to the gallery of photos for Fenway Studios.

 

If I click on Fenway Studios, it correctly goes back to that page. However, when I click on Massachusetts Historic Markers, the link goes all the way back to the root directory page. The clue is that on the gallery page, the chain is as follows:

 

Home > Massachusetts markers > Fenway Studios > Fenway Studios Gallery

 

This chain is missing the History/Culture > Historic Markers categories and may be displaying the default root category.

 

There also seems to be inconsistency whether the last link displayed in that chain is the page you are on or the link to the next larger category. The chain on the Fenway Studios page is

 

Directory Home > History/Culture > Historic Markers > Massachusetts Historic Markers Compare that with the chain on the gallery page shown above.

 

Same thing happens with Pennsylvania Historic Markers and Murals. I suspect many others.

 

On the whole, I am liking the structure, and I love the feature where you choose which picture to display in the waymark page!

0

Share this post


Link to post

Shorelander;

 

I just looked at my email

 

I received an email approving my waymark for Presidential Birthplaces today at 00:17:02, and the previous one to that was another waymark approval for a Mass. Historic Sign on Wednesday the 19th at 20:36.33.

 

I see you added three to the category on 4/20. I haven't seen any confirmation or other notices I usually see as an officer for these. Does this make sense with what you have been observing?

 

N/S

Edited by NorStar
0

Share this post


Link to post

I submitted nearly twenty Waymarks today... some even in my own Category, and some in ones I am in the Officer class of... and some I have no relationship with at all.

 

I didn't receive ANY Emails to confirm receipt, or that new ones are ready for me to Review... NADA!

 

I stopped adding Waymarks when I noticed. But I checked MY WAYMARKS page and they are all there.

 

<_< The Blue Quasar

0

Share this post


Link to post

I submitted nearly twenty Waymarks today... some even in my own Category, and some in ones I am in the Officer class of... and some I have no relationship with at all.

 

I didn't receive ANY Emails to confirm receipt, or that new ones are ready for me to Review... NADA!

 

I stopped adding Waymarks when I noticed. But I checked MY WAYMARKS page and they are all there.

 

<_< The Blue Quasar

I didn't see any of those either. I just sent you a note through Waymarking.com about one and didn't get a copy - wonder if you got it. Does sound like the emailer is broken today.

0

Share this post


Link to post

Nope Hard Oiler... I didn't receive any Emails from you or anything Waymark related... but I did receive Geocaching emails...

 

I think it is just the Waymark side of things.

 

Well, I give you permission to approve the Waymark I submitted today <_<

 

:lol: The Blue Quasar

0

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 8