Jump to content

Usb Garmins And Macs. It Actually Works Now..


Recommended Posts

I haven't frequented the boards recently so maybe I missed it....


When did USB and Macs/VPC suddenly start working?


I bought a Streetpilot 2720 last week. Came with a USB cable. I assumed it wouldn't work on my Mac so I borrowed my daughter's PC to update the firmware and so forth.


Today I was bored and decided to hook it up to my power book via USB and turn on Virtual PC just to see what would happen.


To my amazement Mapsource instantly recoginzed a 2720 was connected. I swapped waypoints back and forth, did some routes and downloaded them. Worked like a charm.


Then I used Garmins' WebUpdater and via VPC and that worked too.


Not sure if the fix was caused by the latest Tigers OSX upgrade or if it was on Garmin's end.


Does anyone know if this new connecitivity with Macs is true with the other USB GPSs from Garmin?


I'm hoping the new 60CSx will work the same way as my 2720.


One can hope anyway. :rolleyes:


After years of using serial cables and USB/PDA adapters to get my GPSV and GPS 60C to talk with my Mac I'm rather stunned that I can finally do it with a simple USB cable and no fuss.


Wonder of wonders.

Edited by jollybgood
Link to comment
Has any one tried GarminUSBTool? It seems like it should work, but I don't have my unit on hand. It is native to OS X so you don't have to mess with VPC.

I downloaded it. It's a beta version and it looks like they have a ways to go on it. I hooked my Quest up to my iBook and the software seemed to be communicating with it (at least from the iBook standpoint). The Quest screen didn't show any signs of receiving or sending data though.

Plus the software only seems to work with tracking data only. Apparently it doesn't send/receive waypoints yet.


We'll see how it progresses.

Link to comment

OK, since GarminUSBTool doesn't send waypoints, how do you get macgpsbabel to work. I have built it with XCode and I get this:


AppleScript Error


sh: line 1: /Users/bruce/Desktop/gpsbabel-1.2.7/macgpsbabel/build/MacGPSBabel.app/Contents/Resources/gpsbabel: is a directory (126)


Does anyone know how to properly build macgpsbabel or where I can get a binary for it?


Thanks a lot.

Link to comment
VPC why? We've been using the keyspan adapter without VPC to connect our Rino 130 to the Powerbook and to the desktop G4. TOPO, MacGPS Pro and Route 66 all work without need of VPC. MacOSX only necessary. MagicTogether

Because I pefer to use Mapsource for waypoint management. Also to update maps when the time comes. Somethign you can't do in OSX without VPC.


Not to mention Garmin's automatic updater for the Streetpilot is really sweet. Just plug in your GPS and it finds everything that needs updated. Voice, firmware, map updates, etc.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...