Jump to content

Mapsource And Virtual Pc


Recommended Posts

Here's my problem. I have a Garmin 60cs and I want to be able to load MapSource into Virtual PC and be able to transfer maps. Right now I have an old HP laptop that I use to do this but that won't be around much longer and I refuse to buy a PC. It is not going to happen, Microsoft is not getting anymore of my money for another copy of that junk they call Windows.


I have bought the Keyspan Serial to USB adapter and the Garmin serial cable. I loaded the Keyspan drivers under OS X and it works fine with transfer waypoints and such with various Mac GPS software. When I load up Virtual PC and have my Garmin connected to my Mac I usually get a kernal panic, I guess because of some sort of device conflict.


Is there anyone out there that has been able to transfer maps to your GPS using Virtual PC? Is it possible to get some step by step instructions?


Thanks in advance for any help.

Edited by NinjaMonkey
Link to comment

I've been using VPC with a USB adapter with no problems.


Here's a few suggestions;


1. Install the windows drivers via VPC for the adapter you have.

2. launch VPC FIRST then plug in your adapter/GPS. This will help prevent OSX from siezing control of the port before VPC sees it.

3. Plug the adapter directly into your laptop or computer rather than into a USB hub.

4. Lettig VPC launch and run for at least two minutes will help tremendously. It can take that long for VPC to get up and running completely.

5. Go into prefernces on VPC and make sure the USB radio box is toggled and that your adapter shows up on the list of USB devices and is selected.


If you're having problems getting Mapsource or whatever to see your adapter/GPS try relaunching VPC. Turning off your GPS and turning it on again etc. But I find the above works 90% of time.

Link to comment

There is another thing you need to do. I tripped on this one and Steve L straightened me out. In Virtual PC, go to Preferences and thenm at the bottom, hit the button called PC settings. In those, look for COM1. You should have had your Keystone adapter plugged in all this time. Now, in COM1, drag down to the adapter panel--I think I remember that when you clicked on COM1 there was a pop-up. If my memory of this is a bit faded, I think you will nevertheless find things clear at that point.

Link to comment

Thanks for help. I no longer kernel panic.


The problem is that it still doesn't work. Windows see's the keyspan adapter when I plug it in and when I go to VPC's settings to change COM1 to the adapter I get a message saying Windows 200 could not use the device because it is already in use. I did make sure to load VPC up before I plugged in the adapter.


Now I'm assuming I was correct to install the keyspan drivers under both OSX and Windows, right?

Link to comment

Here's what has worked for me in VPC 4, 5 and 6.


1. Install the Keyspan drivers for Mac OS X. Don't bother to install the Windows drivers. (No need to remove them if you already installed them, but they aren't used because Windows thinks it's talking to the COM1 or COM2 port and not the USB port.)


2. Make sure the Keyspan adapter is plugged in before you start VPC.


3. Launch VPC, but do not start up your Windows environment.


4. Click the "Settings..." button on the "Virtual PC List" window.


5. Click on "COM1 Port", then use the popup menu to choose your Keyspan adapter. It will have a cryptic name like USA19QI1822P1.1


You can now start up your Windows environment and things should work fine. Be aware, though, that whenever your Windows environment is running, it monopolizes the Keyspan adapter, and you cannot use it from OS X until you shut down Windows.


Now that I've claimed to be an expert :laughing: I have to confess that I can't get this to work with VPC 7 and Mapsource 6.8.0. :laughing: Interestingly, this is exactly what I told herbk to do, and it worked for him with exactly the same software. So, does anybody out there have any suggestions for me?

Link to comment

Thanks for the advice Steve. In fact the way you mentioned was the way I tried to get it working initially.


Right now I'm running VPC 7 with Windows 2k. I do have a copy of VPC 6 around somewhere but I have no clue where the disks are.


I've been trying to get this to work all last weekend and it has been frustrating. I see no reason why it shouldn't work but for some reason it just doesn't. Windows see's the adapter and VPC recognizes it as a USB device and is set to be COM1 but it does nothing.

Link to comment

Just an update. I did get it working!


I'm not sure how, Steve, I followed your instructions and it worked perfectly. Now I'm not sure why considering I tried it the same way before.


The bad news now is I cannot update CitySelect to version 7. My update stops near the end saying I do not have permission to write a certain file. This is why I hate Windows, on a Mac to install a program, I'd only have to drag that program to my Applications folder. I've sent a message to garmin tech support so we'll see if they can manage to figure it out.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...