Jump to content

Explorist 600 - Usb - Unknown Hardware

Recommended Posts

I just used the usb-function for a few weeks (windows XP) without any problems.

But since 3 days windows always says UNKNOWN HARDWARE.

I tried it with 4 different PSs!!! (XP) (also reinstallation for a lot of times)

different other usb-parts have no problems.

I also tried it with a windows ME Laptop.


Is the cable defekt?


Does anyone know the reason?


Thank's a lot.



Edited by freeday
Link to comment

trying deleting the device under system hardware list, then letting it redetect it, if no lucky there, find the specfic driver (good luck) being used and delete it, back it up just in case the later doesn'et work. then reinstall the magallen explorer disc program.


I've had the similiar problem with out devices, a reinstalled xp to fix it but then just realized all I needed to do was create another admin user and run the program again and all is well.



good luck



Link to comment

>>>trying deleting the device under system hardware list, then letting it redetect it, if no lucky there, find the specfic driver (good luck) being used and delete it, back it up just in case the later doesn'et work. then reinstall the magallen explorer disc program.


Thank's, but

I already tried all theses options. :anibad:

Link to comment

I have had a cable problem before(USB) that acted just like you say.... problem is after hooking up damaged cable i also damaged my device. this may not be your case though. after reading through the magellan site and 600 user manual, there is a specific way they want you to connect the explorist 600 to your PC.


"Q: How do I properly connect my eXplorist 400/500/600 to USB and power?

A: Attach the USB connector to the back of your eXplorist GPS receiver prior to connecting AC power and the USB connector into your PC. You must connect your cables and power in this order.


Please follow this connectivity procedure:


1. Connect your eXplorist USB connector to your eXplorist unit

2. Connect your USB connector at the end of the cable to your PC

3. Connect AC power to the eXplorist USB cable"


also note the PDF manual you can Download says allittle more about connecting it.


i would call magellan and ask, the unit is probably under warranty still and they may send you a new cable to try at no cost(demand it)

Link to comment

is it just the explorist that doesn't get recongized ? have u tried any other usb devices to see if they are detected correctly?


did u try inunstalling the usb hub driver under system hardware profile under system. there's the usb driver "unknown hardware" and a usb hub driver under system at the bottom.


try a friends computer to see if it says the same thing. then u know its the unit and not your computer


just checking..


good luck

Edited by flir67
Link to comment

Howdy! I just recently bought a magellan 600 my self and I was having the same issues when hooking up the USB cable... I was thinking it was the drivers etc but NO! actually everything is working fine. It is infact the cable. Notice how the cable looks like it is supposed to be hooked up with the cord comming over the top when infact the cord should be going down behind the device. Ill post some pics when I get home from work. But ya the cable attachment is wierd. If this doesnt fix your problem then I dunno maybe a defective unit.


I asume your trying to put the rectangle lip on the cable on the rectangle hole on the usb connection and then screwing it in. In the same case the connection looks like this...


So the cord is comming out of the top flip it 180 degrees so its going down the back


_ = clip looking thing


| _ | (how you have it) when infact


it should connect like this | ¯ | (how you need it)




so ya ill put some pics up that will explain better

Edited by WickedDrag0oN
Link to comment

I now get a second cable.

in a few days i will know if the unit is broken - hope the cable is broken.


As i said i tried 4 different PC´s all with USB that works with USB-discs

Install/uninstall of software

and one windows-ME-client


USB-Card-Reader always works.


I spent a lot of time in troubleshooting for that problem.

Link to comment

I sent it back for checking the unit. Conclusion: USB-Connection is defect.

I spend a lot of time for this error.


Now, i will get Unit number 4


1. Unit: defect Joystick

2. Unit Bad reception

3. Unit: USB-Connection-error


Thank's for any help in this forum.


The adventure goes on - Magellan eXplorist 600

Link to comment

I had been using my eXplorist600 since May with no issues.... then all of a sudden I started having intermittent battery charging problems. It culminated with the unit not communicating with my PC. So I sent everything in for analysis and repair. It is due back to me on Thursday. I will give you an update then on what happened.... that is, if they even tell me. :lol: But this brings up a serious issue. If the cable was defective, that means that the wiring is extremely delicate and will not hold up to the extreme geocaching abuse (on..off...on...off...etc.) and I will have to purchase a swivel holder to eliminate the stress on the wire. :(

Link to comment

I experienced the 'unknown hardware'-problem with my eX600 as well two weeks ago. Took a good look at the golden colored connection pins and discovered that one of those miniscule pins didn't come out anymore. I imagined that that caused the problem and send the cable back to be replaced. Still waiting for it. So check the connection pins to be sure.

Meanwhile my battery went empty this morning and I am not able to load it without the cable. Maybe it is not such a smart design, the charging and data-cable in one. I hope that I will receive the replacement cable next week as promised by the shop this morning.




Arjen Hulskemper

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...