Jump to content

Etrex Legend Rubber Bumper Un-glued


Followers 3

Recommended Posts

Recently, my etrex legend's rubber bumper has come un-glued. Has anyone else had this problem and found a solution for a repair. I tried some rubber/plastic glue but that didn't work at all. It almost looks as though they used 2 sided tape on the original installation. Any ideas would be welcome, Thanks

Link to comment

If its still under warranty send it back. Even if it isn't, give them a call. Its a common problem and they may repair it for free even if its out of warranty.

 

I think it may come from leaving it in a hot car. It happened twice to mine, but I stopped doing that, it never happened again.

Link to comment

If you can't get it fixed for free, I'd suggest auto trim adhesive. 3M used to make one called Fast Tack (or a misspelling thereof). You'll have the best luck at a real paint-and-body supply house, NOT Pep Boys, Auto Zone, etc. The "good stuff" is designed to attach chrome trim, rub strips, etc. to cars - it will hold up under VERY harsh conditions. I've used this type of stuff for difficult gluing jobs, and it sometimes is the only thing that will work. A very small amount should hold the bumper just fine.

 

They probably did use some kind of industrial-strength double-sided tape. Use 90+% isopropyl alcohol to remove the glue from the bumper; if that doesn't work, try acetone. (test both these solvents on a small area, first, to make sure they don't dissolve the bumper or plastic!)

Link to comment

  When the rubber strip on my eTrex came loose, I first tried using a product called “Shoe Goo” to glue it back.  The rubber material in this strip is the very first thing I have ever found that Shoe Goo fails to stick very well to.  It even sticks well to Teflon, but not to the rubbery material used on my eTrex.

 

  The next thing I tried was plain old RTV silicone rubber, which seems to have worked very well.  More than a year later, the strip is still firmly in place.

Link to comment

My glue also failed on my E-Trex legend and when I e-Mailed Garman thru their Web site I did not get a reply back. I used a contact cement which would not work. I don't want to send it back for repair right now because I'm right in the middle of the main geocaching and backpacking season. Don't know how long it would be gone.

Edited by Red Desert Fox
Link to comment

Thanks to you guys that responded!! Tonight I tried some "DURO Super Glue". Duro is a TM of Henkel Locktite Corp. It appears that the rubber bumper is very secure after settiing up for an hour, although the package said it dries in seconds. The question is will it hold up over a long period of time. Thanks again, #1batman :)

Link to comment

Garmin has great customer service. This happened to me twice with my eTrex Vista. The first time the unit was a month out of warranty, and again about a year later. Both times the unit was repaired at no charge. Not only was the rubber grip replaced, they replaced the entire case! This was an unexpected bonus as the first time I had some deep scratches on the screen. Also both times I had the GPSr back in about a week. I haven't used the Vista much since the second repair as I am now using a 60 CS as my primary unit. As briansnat mentioned it is probably caused by leaving the GPSr in the hot car. Although I have never left it in the sun (I always leave it in the glove box), or gotten any bug spray or sunscreen on it. Garmin is FIRST CLASS all the way!

Link to comment

I received my eTrex Vista back from Garmin today. ;) Just 9 days including 2 weekends after mailing it.

 

They sent me back a unit with a lower serial number than what I sent in. I assume that it is a reconditioned unit and that my old one will be sent to someone else after it is repaired.

 

They transferred my waypoints but not my maps :D . Maps are easy to reload.

 

If anyone else is having a problem with the rubber coming off, I suggest contacting Garmin for an RMA and sending in your unit.

Link to comment

I also experienced this problem with my eTrex Vista. I fixed it myself during a rainy Sunday. ;)

 

I removed the whole rubber bumber. I took me a while to remove Garmin's gooey adhesive from the rubber band and from the unit itself. I finally achieved it using some Goo Gone.

 

Then I used bathroom silicone sealant to glue the rubber band back.

 

It worked very well and took less time than sending it back to Garmin! :laughing:

Edited by goodweather
Link to comment

I had the same thing happen twice. First time, the Etrex was near a leaky bottle of DEET, and I think the fumes make a pretty good glue solvent. That one went back to EMS and they swapped it for new.

 

Happened again, this time I think it was just the heat. I pulled everything apart and cleaned it up. Then put on a strip of double-sided indoor/outdoor carpet tape, trimed to fit with an exacto and wrapped the bumper back on. Been holding up very nicely all summer.

Link to comment

Found this old thread and I thought I'd throw in my complaint.

 

Bought an eTrek Vista in 2008. After less than a year the rubber started coming off. Garmin replaced it under warranty.

 

A year later it's coming off again. It's no longer under warranty. Garmin offered to repair it for $50. But the offered no explanation about why this might have happened.

 

I think I'll try the carpet tape or auto adhesive suggestions offered above.

Link to comment

I would send mine back for repair, but as it seems they replace the entire unit, I don't want to do that. Why not? Well, a bit weird, but I have about 26,000 miles on my Garmin Legend Cx and don't want to go back to 0. And, no, they are not all caching miles--a lot of airplane miles on there.

Edited by GrateBear
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 3
×
×
  • Create New...