Jump to content
Sign in to follow this  
Followers 0
Langner91

Mapsource Registry Error

Recommended Posts

I have Mapsource U.S. Recreational Lakes with Fishing Hot spots central v5.

 

After installing it I get an error that says "There is a problem with the MapSource Registry. Please re-install MapSource and start it again" when I run it.

 

I have uninstalled, repaired, re-installed about a dozen times and continue to get this message.

 

I emailed Garmin Tech Support and received a very nicely detailed message with instructions on fixing my problem. Basically, they told me to uninstall Mapsource, edit my registry to remove both instances of "Garmin" from the software sections of the registry and then re-install the software. Finally, they told me to upgrade to version 6.5 after I get v5 installed and running correctly.

 

I attempted to follow their instructions to the letter, but they don't match what I am seeing. When I attempt to uninstall Mapsource, I see two instances in the "Add / Remove Programs" dialog box. There is a listing for "Mapsource" and one for "U.S. Recreational Lakes with Fishing Hot spots central v5." If I uninstall both, there are no "Garmin" listings to remove from the registry. If I only uninstall one of them (as the instructions from Garmin state), I only see one instance of "Garmin" in the registry and it will not allow me to delete it.

 

I am wondering if anyone else has seen this. I have attempted to install and upgrade, but I am left with the same error. The software was new, but obviously an older version.

 

Anyone have any hints / tricks that I am missing? The software installed fine on my work computer, so I know the disk is good.

 

Thanks in advance.

Share this post


Link to post

I have the old versions of Roads and Recreation and haven't experienced what you have . . . and I was able to upgrade to version 6.5.

 

JV16 Powertools is a very good Registry editor. You might give it a try. It is much "safer" to use that Regedit.

 

What OS do you have? That might have something to do with it. I have Win 2K Pro.

Share this post


Link to post

I think XP is pickier about allowing you to install older software . . . one reason I never upgraded.

 

Good luck . . . :D

Share this post


Link to post

While I have not seen (or fixed) this problem, here is what I would do if I did:

 

First, I would uninstall all MapSource products using the "Add / Remove Programs" as you did previously.

 

Then I would edit the registry manually as follows:

 

Click "START" - select "RUN"

Type in "REGEDIT" (without the quotation marks)

Click "OK"

 

Click on the following "+" signs in the following order:

+ HKEY_LOCAL_MACHINE

+ SOFTWARE

 

Under the "Software" key, locate the "Garmin" key.

Click on the "Garmin" key to highlight it in blue.

 

Press the "Delete" key on your keyboard.

 

Close the registry editor

 

Re-install your MapSource programs starting with "U.S. Recreational Lakes with Fishing Hot spots central v5".

 

Please let me know how it goes if you decide to proceed with it...

Share this post


Link to post

Thanks, those are the exact instructions that Garmin gave me.

 

If I completely uninstall Mapsource, there is no Garmin entry in the registry to delete.

 

Normally, that would be a good thing, right?

 

I have installed tonight four more times, each time with the same error.

 

I have shutdown, restarted, booted clean (no other programs running) and every other trick that I know.

 

This one has me stumped.

 

I even tried the Beta version of mapsource to see if it behaved differently.

Share this post


Link to post

Are you sure you deleted both the HKLM and the HKCU Garmin trees?

 

If that doesn't help:

 

1. Install the whole shebang on a different PC, export the garmin registry trees and compare (again, both HKLM and HKCU). If they are identical, compare the contents of c:\garmin (or wherever you installed MS).

 

2. Install regmon (www.sysinternals.com) on your PC. Set filtering to see mapsource.exe's registry accesses. Note down the point where Mapsource bails out -> try to think what could be the problem (or post on forum and have others think for you ;)). Trust me, the registry settings are pretty common sense, I have successfully added new mapsets by hand on more occasions than I would care to think of.

Share this post


Link to post

Thanks for the additional suggestions. I actually (don't tell Garmin) have the software installed at work. I did that to see if the CD was good. I will go there and export the registry this afternoon, bring it home and compare the two.

 

I uninstalled last night when I grew frustrated at the whole thing. So, just now, I looked in the registry under HKCU and HKLM and there are NO listings for Garmin. There never has been when the software is uninstalled. When the software is installed, there is one in each place.

 

I will compare registry entries in a bit.

 

Thanks for the help!

Share this post


Link to post

If that still doesn't work try a system restore at a point before you originally installed it the first time. That might work.

Share this post


Link to post

Ok, I have compared registries. They are a bit different, but nothing stands out. I am wondering if I should simply merge my work registry with my home registry (garmin entries only)???

 

Also, I installed Regmon and set the filter to mapsource.exe. I launched the program and regmon lists a bunch of entries. Most say "success". A few say "Not Found" and even fewer say "No Entries".

 

Since the last several entries say "Success", I don't see where the program failed.

 

Now I am more confused.

Share this post


Link to post

I had a similar problem with a different software; found out that it was caused by my anti-virus program. I forgot to disable it when I did the install. Something you might want to check.......Good luck

Share this post


Link to post

I've got FHS 5.0 East. Here are the two entries. I hope this helps.

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Garmin\MapSource\Families\US Recreational Lakes with Fishing Hot Spots® East v5]

"DataInstallDir"="C:\\Program Files\\MapSource\\"

"SourceDir"="D:\\"

"ID"=hex:4f,00

"MDR"="C:\\Program Files\\MapSource\\FHSV5_East_mdr.img"

"IDX"="C:\\Program Files\\MapSource\\FHSV5_East.mdx"

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Garmin\MapSource\Families\US Recreational Lakes with Fishing Hot Spots® East v5\1]

"Notice"="C:\\Program Files\\MapSource\\FHSV5_East\\license.txt"

"Bmap"="C:\\Program Files\\MapSource\\FHSV5_East.img"

"Tdb"="C:\\Program Files\\MapSource\\FHSV5_East.tdb"

"Loc"="C:\\Program Files\\MapSource\\FHSV5_East"

Share this post


Link to post

First thanks everyone for the support, I was able to gleam enough from the suggestions to get the MapSource City Select V7 update to install on my computer.

 

This is a new computer (April 05) running Windows XP with SP-2.

 

Each time I tried to install Version 7 it loaded all the files but gave the InstallShield error message 1628 " Failed to complete installation" as it tried to write to the registry. BTW - It would blow up Version 6 too make it or any other version of MapSource in-operable. I'd click on the ICON and the error message would inform me there was something wrong with the Garmin Registry and to install the software again... I did just that (probably 10 times).

 

The only software I could get to successfully reload was the Topo version.

 

However it may not be a problem with this software and more likely a problem with my machine.

 

Here's how I got V.7 to install. I used my Wife's laptop running the same OS and installed both version 6 and version 7 without unlocking the maps. I then went into the her registry and exported the to Garmin tabs. One is in Current User, the other is in Local Machine. I then placed these on my desktop and double-clicked them and MapSource fired right up. I then unlocked both maps and am back in business...

 

V.7...

I checked a few of my local roads that had been incorrectly mapped in V6 and they had been fixed in V7. I'll post a review after I've had time to use it.

Edited by markhp

Share this post


Link to post

While I have not seen (or fixed) this problem, here is what I would do if I did:

 

First, I would uninstall all MapSource products using the "Add / Remove Programs" as you did previously.

 

Then I would edit the registry manually as follows:

 

Click "START" - select "RUN"

Type in "REGEDIT" (without the quotation marks)

Click "OK"

 

Click on the following "+" signs in the following order:

+ HKEY_LOCAL_MACHINE

+ SOFTWARE

 

Under the "Software" key, locate the "Garmin" key.

Click on the "Garmin" key to highlight it in blue.

 

Press the "Delete" key on your keyboard.

 

Close the registry editor

 

Re-install your MapSource programs starting with "U.S. Recreational Lakes with Fishing Hot spots central v5".

 

Please let me know how it goes if you decide to proceed with it...

 

Great tip NEO_GEO!! This did the job for me.

Share this post


Link to post

I have had that exact same problem and have used MapsetToolkit to remove the registry entries of each Mapsource product individually until I fix what has it crashing. Mapset toolkit allows you to uninstall the registry values of each product individually and will show you a list of what is installed. It only takes a second to do this and is a very quick fix for MapSource error.

 

MapsetToolkit can be found here: http://cypherman1.googlepages.com/home

Share this post


Link to post

I recently had the same issue when I installed some topo maps made by someone here. When I installed it, I wasn't sure exactly where to install it to, so after it installed, I moved the folder. I got that exact same error every time I tried to open Mapsource. Re-installed Mapsource and still the same thing. I then placed the folder back to it's original place that it was installed to and everything is working great since. So I'm thinking you must have moved the maps folder or it did not install to the correct place.

Share this post


Link to post

While I have not seen (or fixed) this problem, here is what I would do if I did:

 

First, I would uninstall all MapSource products using the "Add / Remove Programs" as you did previously.

 

Then I would edit the registry manually as follows:

 

Click "START" - select "RUN"

Type in "REGEDIT" (without the quotation marks)

Click "OK"

 

Click on the following "+" signs in the following order:

+ HKEY_LOCAL_MACHINE

+ SOFTWARE

 

Under the "Software" key, locate the "Garmin" key.

Click on the "Garmin" key to highlight it in blue.

 

Press the "Delete" key on your keyboard.

 

Close the registry editor

 

Re-install your MapSource programs starting with "U.S. Recreational Lakes with Fishing Hot spots central v5".

 

Please let me know how it goes if you decide to proceed with it...

 

That took care of it, Neo Geo. Or, at least it allowed me to re-install my old version. Now I get to see if I can apply the upgrade. Thanks to all for your help.

Share this post


Link to post

In addition to your Mapsource U.S. Recreational Lakes with Fishing Hot spots central v5, do you have Mapsource Waypoint & Route Manager loaded?

How about any other Mapsource program like Topo?

Or any of the 'patches' that Garmin has on their web site?

I stick to Magellan but have Garmin Mapsource Topo to do some simple things.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  
Followers 0

×
×
  • Create New...