Jump to content

Garmin Etrex Legend Troubles..


CharlieZulu
Followers 0

Recommended Posts

I have a 1-yr old Legend and tonight the display started flipping out on me... crazy horizontal lines, etc. Can cure the problem temporarily by tapping on the display.

 

Anyone seen this? Anyone have a cure? Common for this model, or have I just abused the little guy once too often??

 

Chris

Link to comment

Hi Chris,

 

I've read about that problem on the sci.geo.satellite.nav newsgroup. You will likely have to send your unit in for repair. If you talk to Garmin (Olathe, KS) they may still honour the warranty if it is slightly over the 1 year mark. Whatever you do, don't send the unit to an autorhorized repair depot in Quebec - you won't see it back for a long time - insist on dealing directly with Garmin US. I did that and had mine repaired (different problem) and returned in about 10 days. It cost me a small amount extra for duty, but worth it to get it back in good time. Good luck!

 

Ted.

Link to comment
It cost me a small amount extra for duty,

 

I'm pretty sure there isn't any duty on GPS units or any receiver for that matter. Garmin needs to be instructed to mark the shipment properly. The buffoons at the customs brokers will try to apply a duty to it so they can then charge a clearing fee. Don't get ripped off.

Link to comment

I knew there must be a link somewhere on this. Looks like a pretty common problem. Too bad I didn't know about this before buying it. :mad:

 

It's just coming up on a year old, and I will talk to the retailer about it. Possibility of getting a replacement unit, I think ( would be nice :unsure: )

 

Thanks again, guys.

 

chris

Link to comment
It cost me a small amount extra for duty,

 

I'm pretty sure there isn't any duty on GPS units or any receiver for that matter. Garmin needs to be instructed to mark the shipment properly. The buffoons at the customs brokers will try to apply a duty to it so they can then charge a clearing fee. Don't get ripped off.

I think the duty cost me about $14, so I wasn't too upset, given the fantastic turn-around time. If I recall correctly, the package was marked as the contents being a GPS receiver. Is there a specific instruction we could give to Garmin to identify the package so that duty would not be charged? Even though it wasn't a great amount, it's a shame to waste money unneccessarily. That $14 would buy me gas for half a day of caching!

Link to comment

Update (for those who care!)

 

Radioworld was really no help.. they suggested I send it back to them, and they would sent it to Raytech... uh-oh. Or, I could send to to Raytech on my own.

 

If my unit was 3 months old or less, Radioworld would have just swapped it out.

 

Called Garmin USA (20 minute wiat in the queue) and they gave me an RMA number, etc and said they would do the warranty repair (said I did not even have to produce the Bill of Sale!... "we trust ya"..). I have access to a US address, so will use that for the return, and either pick it up or have one of my colleagues pick it up.

 

Now, I have to bite the bullet and actually start the process and live without it... the unit operates fine about 50% of the time, and I can bring it back by tapping on the display.

 

stay tuned...

Link to comment

This is a known problem with the Etrex units. My Vista started doing it after about 2 years. It has to do with a loose connection inside

 

If you go to yahoo groups, and join the Vista one, there is pictures of what needs to be done to fix it. If you are handy with electronics you can probably do it yourself. You do have to break the waterproof seal.

 

As for the RMA, there is an autorized Garmin repair centre in Montreal. The name escapes me but if you call Garmin and tell them you are in Canada they should be able to give it to you. For my Vista, they wanted $180 to do a complete overhaul of the unit. I bought a GPS MAP60CS instead and have been very happy.

 

Good luck.

 

Chuck

Link to comment

If you call Garmin International (Kansas?) and tell them you're not satisfied with the Quebec reps, they'll likely offer a good deal to have it fixed... then you just have to make sure they mark the package going back to Canada as "warranty items" so that it's not charged duty, and also make sure they send it as "first class regular mail" (snailmail) so that the brokers don't get their hands on it.

Otherwise, it'll cost you an arm and a leg.

Link to comment
I have a 1-yr old Legend and tonight the display started flipping out on me... crazy horizontal lines, etc. Can cure the problem temporarily by tapping on the display.

 

Anyone seen this? Anyone have a cure? Common for this model, or have I just abused the little guy once too often??

 

Chris

Not sure this has been said on this thread or not.

I had a similar problem with my Venture this spring. Vertical lines messing up the display. I was a little worried the unit was on the fringe.

I found that the problem was the battery terminals were dirty and or loose. Rechargeable batteries are smaller in size than disposable ones. I streatched the connections. Second, i used a pencil earaser and "rubbed" off potential grime/dirt from the connection, similar to what you should/would do to a cellphone.

It done the trip, haven't had it happen again/since.

 

IMHO, no need to send anywhere for repair.

Link to comment

Well this thread hits home quite well!

 

I did an extensive amount of research into this issue. I have an eTrex Venture that had the same lines and same display corruption. I would say its likely an issue with the entire eTrex line rather than any one model.

 

I did have mine RMA'ed with Garmin in Olathe KS. I had heard horror stories from others here about the Montreal depot, and decided to speak directly with the US department. They did not give me one once of hassle with returning the product to them. They even shipped my product back to me direct to my Canadian address. As was mentioned here earlier, Do yourself a favor and avoid the Canadian Depot. The US folks were more than accomodating.

 

The unfortunate news is that my eTrex venture worked for around 4 months, but is back to displaying the issue it had in the first place. I believe they even sent me a new, non-refurbished unit. Go figure. The eTrex has been great to me, but I guess some things cannot be fixed.

 

A good tap with my knuckles usually does the trick. Other than that, I don't know what to suggest!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 0
×
×
  • Create New...