Jump to content

Dead Sportrak Map - Waterlogged!!


Followers 1

Recommended Posts

I recently went on vacation in Florida and stupidly tested the waterproofness of my Magellan Sportrak Map that I've had for almost 3 years now.

 

The first time it went in it worked fine, floated and everything. That was on the non-ocean side of Sanibel Island where the salinity is less than that of the ocean.

 

The batteries were low, so I changed them later that day. The next day I tried them again on the ocean side of the island. Boom! Dead moments after taking it into the water!

 

Now it won't power up at all! I opened the battery compartment, and emptied out what salt water made it into it. I then took a hair dryer and attempted to dry it out. There is still some tiny water droplets on the inside of the screen.

 

I've replaced the batteries and it still won't power on. I've tried using external power and it still won't power on.

 

Could it be the internal battery? Could it be anything else?

 

Has anyone else had experience with waterlogging their GPS??

 

Please help!!

 

GEOCACHING AT STAKE!

 

-- Inspector Gadget <_<<_<:laughing:<_<:laughing:

 

p.s. why using GPS in the water you ask? I felt a barnacle-encrusted box in the ocean and had wanted to mark the position. I think it was old crate or something. Couldn't pull it up as it was deeply buried, cutting my hands in the process.

Link to comment

Trying to power it up while it was wet was a bad thing! :laughing:

 

You should do everything you can to get all the moisture out of the unit ..... by placing in front of a running dehumidifier, or placing it in a container with desecant (water absorbing kitty litter like granuals), or just anywhere it is dry with good circulation. I've read other posts of water-dead units that came back to life after a good drying out! Good Luck. <_< ImpalaBob

Link to comment

Go to Michael's or Ben Franklin's or another craft shop and get Flower-Dri or another desiccant. Fill a one quart ziplock bag about half full and put the unit into the bag. Let stand for 48 hours someplace warm (like outside in the sun or on top of your fridge). Change out the desiccant and repeat. If you are lucky, it will come back to life. If you aren't, the salt ate your electronics and it is dead, dead, deadski.

 

Edit: Flower-Dri

Edited by Sputnik 57
Link to comment

The salt and water is conductive enough to cause short circuits (no new flash there I know). The problem is that tiny droplets get lodged under the chips and between tiny pieces where they don't dry out, and continue shorting out the thing. Your best bet is to go to Radio Shack and get a can of electrical component cleaner (comes in an aerosol can for like $5) or soak it all in alcohol. One word of warning, the alcohol and/or the electrical cleaner may obscure the clear plastic lens over the display. Test carefully before going all out. But if you can do it, that should flush out the small dropplets causing you problems. I've done this process twice already, once when my liquid cooling system in my computer leaked (Yeah, I'm a geek with a $6000 computer that is liquid cooled), and once when my buddy dropped his cell phone in the pool (moron). It works because the cleaner/alcohol is more volatile and thinner and run out and dries more easily.

Link to comment

Thanks all! Will definitely try drying it out even more!

 

From everyone's responses it sounds like if the internal battery were shorted that it would still power up, just not remember anything. I'm not sure if this model even has an internal battery or just uses flash memory for everything.

 

I'll keep y'all posted.

 

Incidentally, how did water get in? Since I knew I would be testing its waterproofness I had tightened the battery cover well and did not press any buttons while it was underwater.

 

<_<

Link to comment

Distilled water IS non-conductive, as is the alcohol and the electrical component cleaner. The big difference is what they leave behind as far as residue. The cleaner is designed to dry as residue free as possible. Plus it offers a nice convenient aerosol package that lets you really blast the nasties out from under the components. Alcohol acts as a drying agent for water (as do most other volatile liquids) so if you end up soaking it in distilled water, then definately use the cleaner or alcohol to dry the internals. (The ear drops used to cure swimmers ear are largely just alcohol because the evaporating alcohol dries the water denying the

bacteria the moisture they need to grow.)

 

As for how the water got in, it's anyone's guess. If the cover was even slightly misaligned it could have caused to to leave an opening. Also if you tightened it too much it may have caused it to deform and change shape temporarily (like pushing on the lid of a Snapple). Judging by the fact that you said that the first time it did not leak, there must have been some problem with the seating of the cover. You could also have gotten something in between the cover and seating surface (hair, fuzz, sand, etc).

Link to comment

I agree with much of what has been said here. If it has been in salt water, you should immediately remove the batteries and dunk in distilled water and swish it around. The case should be opened (unscrew it.) shake off excess water, then pour alchohol on the circiut board. Shake this off, and dry gently with a hair dryer. Take everything apart.

 

I read an article once about the above for handheld radios in salt water. The key is to get rid of the salt as soon as possible. My son dropped a cell phone in a toilet once (clean water.) I still used distilled, and alchohol and dryer. The battery shorted, and was ruined, but the phone survived perfectly (I unscrewed the case and took it all apart.)

Link to comment

There is six screws that will open the case. (I'm typing this from memory so check with real life before attempting anything I say. It happened to me, twice.)

 

PROCEED AT YOUR OWN RISK!!!

 

Remove the batteries.

 

Remove the screws that hold the unit together.

 

Carefully seperate the two halves watching how the innards come apart as you will have to replace them in reverse order.

 

You should have two basic pieces. One is the front, set this aside for the moment.

 

The other should be three pieces attached with wires. It will be the rear portiaon of the case attached with the data and power wires to the main board. The main board and the screen.

 

The screen is attached with a ribbon cable. The ribbon cable is attached to the main board via a connector. Inspect carfully. You should see a portion of the connector that you can pull straight away from the main board. This will release the screen. PAY CLOSE ATTENTION TO THE ORIENTATION OF THE RIBBON.

 

Follow the above advise with an electronics cleaner. MAKE SURE IT IS NOT A LUBRICANT! I made that mistake once by not reading the label carefully and fried a computer. Yes, literally sparks!

 

The important thing is to do it soon. Buy a couple of cans of cleaner because it's cheaper than the GPS.

 

You will need to be carefull with some of the components that have an adhesive tape on them, especially the screen. Using too much cleaner will cause it to delaminate.

 

Set it aside to dry.

 

Turn you attention to the front half of the case. Remove the rubber buttons membrane and clean all of this. Be careful of solvents on the clear plastic.

 

The important thing it to get the salt water out. Then let it dry out.

 

Let it dry for overnight, at least. A couple of days preferably. Then reassemble. (Why do I want to say "Stephanie" after "reassemble?")

 

Just because the unit doesn't have a display doesn't mean it's not powering up. Listen for the beeps as you key it. Hit power, wait a couple of seconds and then hit enter a couple of times. Did you hear the beeps? If so, it's a screen problem.

 

I had a unit that we dropped in fresh water and it dried out fairly well in a few hours after taking it apart like described above. The other time it was splashed heavily by saltwater while on a PWC. It took a bit more effort to get it to come back that time. Even then the screen had horizontal streaks in it for the longest time. But in the end it eventaully returned to full service.

 

I must stress however, the above steps should only be taken if you are comfortable with electronics repair and you assume all risks. I worked for me, but I can't guarantee it will work for you.

 

Hope this helps.

Link to comment

:lol::D:lol::D:lol::lol:

 

IT'S ALIVE!!! MY MAGELLAN SPORTRAC MAP IS ALIVE!!

 

I did as you suggested and opened up the case. I was relieved to see that the rubber gasket between the two halves did not require any prying once the screws were removed.

 

This allowed the back to come off easily still held to the front by 6 wires for power (2 for battery, 4 for external).

 

I then removed a screw holding the circuit board to the front of the unit that was about in the middle. This allowed the front half of the unit to come off from the circuit board.

 

There did not appear to be much water left inside except for a few tiny droplets on the inside of the clear plastic part of the front half of the case. The metal guards that protect a lot of the components on the circuit board showed some small amount of rust at their corners, but there was no seawater left. I wiped some of these corners down with a cloth.

 

Also, it did not look like the unit uses an internal battery, and likely completely depends on flash for its memory, which is a definite good sign!

 

I then very gently pried the ribbon cable for the display as you mentioned. It had a little plastic piece that held the display ribbon in its connector, it sort of served to wedge the ribbon in place.

 

I then saw the root cause of why the GPS wouldn't function-- a thin membrane of plastic that surrounds the keyboard input part of the circuit board was saturated with a tiny film of water, seawater I assume. The contacts all appeared to still be wet. This would make the keyboard completely SHORTED! That's why the unit wouldn't power up! It didn't know I was even pressing the ON button!

 

So I removed this membrane, which was really two or three layers of thin plastic held together as one piece. This membrane was attached to the circuit board at two large contact pads near the lower left which I assume serves as a ground plane for the keyboard. I wiped down what I could but decided it was too thin to try to manually clean.

 

I then sprayed down the exposed portion of the circuit board with a contact cleaner, being careful not to get cleaner inside the metal boxes that serve to protect the more sensitive components.

 

I left the entire disassembled unit just sit out overnight on a piece of paper towel.

 

This morning it was like Christmas, I had to see if it would work. I put the keyboard protective membrane back onto the keyboard input part of board, attaching it with a tiny drop of super glue. I plugged the display back into the board, put the display and board back onto the front piece, hooked up some batteries and powered it up without completing the assembly.

 

IT WORKED! The display showed the last known point it had, where in the ocean I had used it off the coast of Sanibel.

 

The buttons respond to input, the memory is still intact with all of the firmware, maps and waypoints!

 

The only thing left to confirm is if the unit can still receive signals and calculate its position. I didn't have time to do that before I had to go to work to test it further.

 

I'll let y'all know how it works out tonight as I plan a celebratory geocaching expedition.

 

THANK YOU THANK YOU THANK YOU to all that wrote back so quickly and with so much detail! I hope this thread helps someone else down the road.

 

Now I know not to believe the claims of "waterproof" on these units any more! (Water resistant maybe, but definitely not submersible!)

 

Regards,

 

Inspector Gadget

:lol::lol:

Edited by inspectorgadget
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Followers 1
×
×
  • Create New...